SuiteCRM: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in SuiteCRM
Affects SuiteCRM before 7.15.2 and 8.0.0 through 8.10.1 where the Upgrade Wizard commit flow is used. Fixed in 7.15.2 and 8.10.2.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 7.15.2, 8.10.2
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. The attacker must use the Upgrade Wizard commit flow, where the hidden zip_to_dir parameter is trusted.
- Last modified
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 16/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: total
Summary
SuiteCRM's Upgrade Wizard fails to restrict file paths during package uploads, so an attacker can reach it remotely over the network, but only after logging in with administrator-level access. Such an attacker can copy files outside the intended directory, overwrite application or configuration files, place executable PHP under the web root, or cause a denial of service.
Read the original description
SuiteCRM is an open-source, enterprise-ready Customer Relationship Management (CRM) software application. Prior to 7.15.2 and 8.10.2, the Upgrade Wizard commit flow trusts the hidden zip_to_dir parameter, while clean_path() does not reject traversal sequences. An authenticated administrator can copy extracted package files outside the intended destination, overwrite application or configuration files, place executable PHP under the web root, or cause denial of service. This issue is fixed in versions 7.15.2 and 8.10.2.
cve.now Index
- Exploitation0/40No signal
- Exposure8/25Specific setups only, reachable over the network
- Reach?/20Unknown. No tracked technology or package matched
- Severity8.2/10CVSS 7.2, total technical impact per CISA
- No patch0/5No signal
What would change the score
- Would score about 66 if added to CISA KEV
- Would score about 61 if CISA's SSVC rates exploitation active
- Would score about 23 if CISA's SSVC rates it automatable
What to do
Check whether your setup matches what the bug needs.
The attacker must use the Upgrade Wizard commit flow, where the hidden zip_to_dir parameter is trusted.Upgrade to a fixed version: 7.15.2, 8.10.2.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: total
- Record last updated
Affected versions
- SuiteCRM SuiteCRM
fixed in 7.15.2; From 8.0.0 · fixed in 8.10.2
Evidence 5
- Advisory
- Repository
- Repository
- Repository
- Repository
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-63213
Is CVE-2026-63213 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
The Upgrade Wizard commit flow trusts a hidden zip_to_dir parameter, so an authenticated administrator can write extracted package files to arbitrary locations the PHP process can reach. This allows overwriting application files, placing and running PHP files under the web root, and denial of service.Source: github.com
Which versions are affected by CVE-2026-63213?
SuiteCRM: before 7.15.2; from 8.0.0 before 8.10.2.Source: cve.now feed data
Am I affected, and how do I check?
Versions before 7.15.2 and versions from 8.0.0 up to 8.10.1 are affected. The issue involves the Upgrade Wizard commit flow, so compare the installed version number against these ranges and note whether that flow is used.Source: github.com
How do I fix CVE-2026-63213?
Upgrade to 7.15.2 on the 7.x line or to 8.10.2 on the 8.x line. The sources do not list a workaround.Source: github.com