Skip to main content
← Vulnerabilities

SuiteCRM: Non-admin user creates SchedulersJob: SSRF via cron

Affects SuiteCRM 7.15.1 and earlier 7.x and 8.10.1 and earlier 8.x, where an authenticated non-admin user can use the REST API v8. Fixed in 7.15.2 and 8.10.2.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

7.1HighCNA
Exploited
No known exploitation
Fix
Fixed in 7.15.2, 8.10.2
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Requires an authenticated user account on SuiteCRM v7.15.1 or earlier 7.x, or v8.10.1 or earlier 8.x, using the REST API v8. The injected job must be executed by cron.php, which runs it with system-level (admin) privileges.

Published
Last modified
15/100 · provisional
Specific setups only
None on Exploit-DB, Metasploit or GitHub

Summary

SuiteCRM, an open-source customer relationship management application, has a flaw in its V8 module API that lets a low-privileged logged-in user create scheduler jobs that the server later runs with system privileges. An attacker can use this to make the server send requests to internal or external hosts, which may expose internal services; the attack is carried out over the network and needs a low-privilege login but no user interaction.

Read the original description

SuiteCRM is an open-source, enterprise-ready Customer Relationship Management (CRM) software application. Prior to 7.15.2 and 8.10.2, the V8 module API lacks module-level authorization and permits a low-privileged user to create SchedulersJobs records with attacker-controlled target values. The affected flow begins at /Api/V8/module and uses SchedulersJobs, target, cron.php, and url:: to carry attacker-controlled data or authorization state into the security-sensitive operation. Cron.php later executes the queued job with system privileges, and the url:: target makes server-side requests to internal or external hosts, can follow redirects, can persist as a recurring job, and may expose internal services. This issue is fixed in versions 7.15.2 and 8.10.2.

cve.now Index

15Pcve.now Index 15 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure8/25Specific setups only, reachable over the network
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity7.1/10CVSS 7.1
  • No patch0/5No signal

What would change the score

  • Would score about 65 if added to CISA KEV
  • Would score about 60 if CISA's SSVC rates exploitation active
  • Would score about 22 if CISA's SSVC rates it automatable

What to do

  • Check whether your setup matches what the bug needs.

    Requires an authenticated user account on SuiteCRM v7.15.1 or earlier 7.x, or v8.10.1 or earlier 8.x, using the REST API v8. The injected job must be executed by cron.php, which runs it with system-level (admin) privileges.
  • Upgrade to a fixed version: 7.15.2, 8.10.2.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • SuiteCRM SuiteCRM

    fixed in 7.15.2; From 8.0.0 · fixed in 8.10.2

Evidence 5

  1. Advisory
  2. Repository
  3. Repository
  4. Repository
  5. Repository

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-63111

Is CVE-2026-63111 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

An authenticated non-admin user can create scheduler job records with arbitrary target values, including a url:: prefix. When cron.php runs such a job, it runs with system admin privileges and can make HTTP requests from the server to internal hosts, cloud metadata endpoints and localhost services.Source: github.com

Which versions are affected by CVE-2026-63111?

SuiteCRM: before 7.15.2; from 8.0.0 before 8.10.2.Source: cve.now feed data

Am I affected, and how do I check?

Versions 7.15.1 and earlier 7.x and 8.10.1 and earlier 8.x (from 8.0.0) are affected, when the REST API v8 is in use and the user has an authenticated account. To check an installation, compare its installed version number against these ranges.Source: github.com

How do I fix CVE-2026-63111?

Upgrade to SuiteCRM 7.15.2 or later in the 7.x line, or to 8.10.2 or later in the 8.x line.Source: github.com