Dream Displays has command-line argument injection in yt-dlp invocation
Dream Displays versions 1.5.0 through 1.8.1 let user-controlled input influence arguments passed to yt-dlp. Fixed in 1.8.2.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Unclear
- Fix
- Fixed in 1.8.2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: yes
- Technical impact: partial
Summary
Dream Displays, a Minecraft mod for showing streamed videos on in-game screens, is affected. An attacker who can influence the input passed to the yt-dlp video downloader under certain conditions could inject extra command-line options, potentially changing how yt-dlp behaves.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
Dream Displays provides in-game screens for streaming videos in Minecraft. From 1.5.0 until 1.8.2, user-controlled input can influence arguments passed to `yt-dlp` under specific conditions. Unintended command-line options may be interpreted by `yt-dlp`, potentially altering its behavior. This issue is fixed in version 1.8.2.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: yes · Technical impact: partial
- Record last updated
Affected versions
- arsmotorin dreamdisplays
From 1.5.0 · fixed in 1.8.2
References 5
Questions about CVE-2026-62968
What does this mean?
User-controlled input could add unintended command-line options that yt-dlp interprets, which could change how yt-dlp behaves.Source: github.com
Am I affected, and how do I check?
Dream Displays versions 1.5.0 through 1.8.1 are listed as affected. To check, look up the installed Dream Displays version in the app and compare it with that range.Source: github.com
What should I do about it?
Upgrade Dream Displays to version 1.8.2 or later, which is the listed fixed version.Source: github.com
Is it being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data