Pocket ID: Client credentials grant allows any OIDC client to obtain tokens for arbitrary audiences
Pocket ID versions 1.11.0 through 2.9.0 are affected where services use the client credentials grant and trust its access tokens for service-to-service authorization. Fixed in 2.10.0.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 2.10.0
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. Pocket ID version 1.11.0 through 2.9.0 (affected range per advisory package listing). The client credentials grant must be used (grant_type=client_credentials) with a valid authenticated OIDC client. Impact depends on deployment: resource servers must trust Pocket ID access tokens for service-to-service authorization.
- Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
- Exposure8/25Specific setups only, reachable over the network
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity7.7/10CVSS 7.7
- No patch0/5No signal
What would change the score
- Would score about 66 if added to CISA KEV
- Would score about 61 if CISA's SSVC rates exploitation active
- Would score about 23 if CISA's SSVC rates it automatable
CVE-2026-62662 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.7 (high) and affects pocket-id; fixed in 2.10.0.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 16/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 2.10.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Pocket ID, an OIDC provider, lets an attacker who is already authenticated as an OIDC client remotely obtain signed access tokens for other clients or arbitrary audiences. Where resource servers trust these tokens for service-to-service authorization, this bypasses audience-based access controls and can allow unauthorized data access or actions.
Read the original description
Pocket ID is an OIDC provider that allows users to authenticate with their passkeys to services. From 1.11.0 until 2.10.0, createTokenFromClientCredentials in backend/internal/service/oidc_service.go accepts the client-controlled resource parameter and embeds it directly in the access token aud claim without validating that the audience is registered or that the requesting client may access it. Any authenticated OIDC client can therefore obtain a Pocket ID-signed token naming another client or an arbitrary audience. The /api/oidc/introspect endpoint cannot distinguish the unauthorized token because it treats a token as active when the introspecting client's identifier matches the attacker-selected audience. In deployments where resource servers trust Pocket ID access tokens for service-to-service authorization, this bypasses audience-based access controls and can permit unauthorized data access or actions; deployments that do not use these tokens for resource-server authorization have no immediate exploitable impact. This issue is fixed in version 2.10.0.
What to do
Check whether your setup matches what the bug needs.
Pocket ID version 1.11.0 through 2.9.0 (affected range per advisory package listing). The client credentials grant must be used (grant_type=client_credentials) with a valid authenticated OIDC client. Impact depends on deployment: resource servers must trust Pocket ID access tokens for service-to-service authorization.Upgrade to a fixed version: 2.10.0.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- pocket-id pocket-id
From 1.11.0 · fixed in 2.10.0
Evidence 4
- Advisory
- Repository
- Repository
- Repository
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-62662
Is CVE-2026-62662 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
The client credentials grant does not validate the resource parameter before copying it into the aud claim of the issued JWT. An authenticated OIDC client can therefore obtain tokens whose audience is an arbitrary service.Source: github.com
Which versions are affected by CVE-2026-62662?
pocket-id: from 1.11.0 before 2.10.0.Source: cve.now feed data
Am I affected, and how do I check?
Affected versions are 1.11.0 through 2.9.0, per the advisory package listing. Impact depends on deployment: it matters where services use the client credentials grant and validate incoming bearer tokens against Pocket ID's JWKS. To check, look at the Pocket ID version in use and whether any service relies on client credentials tokens from Pocket ID.Source: github.com
How do I fix CVE-2026-62662?
Upgrade Pocket ID to version 2.10.0 or later, which is the first fixed version in the affected range.Source: github.com