SuiteCRM: Incorrect Access Control in V8 relationship creation via missing edit authorization
Affects SuiteCRM 8.0.0 up to 8.10.2 and earlier 7.x releases before 7.15.2, through the V8 API's one-to-many relationship creation. Fixed in 7.15.2 and 8.10.2.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 7.15.2, 8.10.2
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. The bug is in the V8 relationship creation API endpoint for one-to-many relationships
- Last modified
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 16/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
A low-privileged user of SuiteCRM, an open-source customer relationship management application, can exploit a flaw in its V8 API relationship endpoint to reassign records and alter ownership and security-relevant relationships, which can expand access across users and manipulate workflows. The attack is carried out remotely over the network with only low-level login credentials and requires no user interaction.
Read the original description
SuiteCRM is an open-source, enterprise-ready Customer Relationship Management (CRM) software application. Prior to 7.15.2 and 8.10.2, the POST /Api/V8/module/{moduleName}/{id}/relationships/{linkFieldName} endpoint checks only view and list permissions before a one-to-many relationship writes a target record's foreign key, without enforcing the required edit permission. A low-privileged user can reassign records, alter ownership and security-relevant relationships, expand cross-user access, and manipulate workflows. This issue is fixed in versions 7.15.2 and 8.10.2.
cve.now Index
- Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
- Exposure8/25Specific setups only, reachable over the network
- Reach?/20Unknown. No tracked technology or package matched
- Severity8.1/10CVSS 8.1
- No patch0/5No signal
What would change the score
- Would score about 66 if added to CISA KEV
- Would score about 61 if CISA's SSVC rates exploitation active
- Would score about 23 if CISA's SSVC rates it automatable
What to do
Check whether your setup matches what the bug needs.
The bug is in the V8 relationship creation API endpoint for one-to-many relationshipsUpgrade to a fixed version: 7.15.2, 8.10.2.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- SuiteCRM SuiteCRM
fixed in 7.15.2; From 8.0.0 · fixed in 8.10.2
Evidence 5
- Advisory
- Repository
- Repository
- Repository
- Repository
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-61650
Is CVE-2026-61650 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
An authenticated low-privileged user can change security-relevant relationships and ownership fields on records they should only be able to read. This allows unauthorized reassignment of records, expanded access to other users' records, and manipulation of workflows.Source: github.com
Which versions are affected by CVE-2026-61650?
SuiteCRM: before 7.15.2; from 8.0.0 before 8.10.2.Source: cve.now feed data
Am I affected, and how do I check?
SuiteCRM versions before 7.15.2 and versions from 8.0.0 up to 8.10.2 are affected. The flaw is in the V8 relationship creation API endpoint for one-to-many relationships, so check your installed version number against these ranges.Source: github.com
How do I fix CVE-2026-61650?
Upgrade to 7.15.2 if you run the 7.x line, or to 8.10.2 if you run the 8.x line.Source: github.com