Skip to main content
← Vulnerabilities

SuiteCRM: isSelfRequest() bypass via substring match allows SSRF to internal services

Affects SuiteCRM 7.15.1 and earlier, and 8.0.0 through 8.10.1, where the earlier 7.15.1 SSRF fix is bypassed. Fixed in 7.15.2 and 8.10.2.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

7.7HighCNA
Exploited
No known exploitation
Fix
Fixed in 7.15.2, 8.10.2
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Affected when SuiteCRM is at version 7.15.1 or earlier, or 8.10.1 or earlier, where the 7.15.1 SSRF fix is bypassed.

Published
Last modified
16/100 · provisional
Specific setups only
None on Exploit-DB, Metasploit or GitHub

Summary

SuiteCRM, an open-source customer relationship management application, contains a server-side request forgery flaw in its external host validation, where a substring check in the self-request logic lets an authenticated attacker reach internal services over the network. An attacker with low-privilege login can place the server's hostname in a URL path to get around the IP validation and make the server send requests to internal systems, exposing high-impact confidential data.

Read the original description

SuiteCRM is an open-source, enterprise-ready Customer Relationship Management (CRM) software application. Prior to 7.15.2 and 8.10.2, the SSRF protection added in 7.15.1 uses a substring comparison in isSelfRequest() rather than hostname equality. The affected flow begins at validate_external_host() and uses isSelfRequest(), and stripos() to carry attacker-controlled data or authorization state into the security-sensitive operation. An authenticated attacker can place the server hostname in a URL path to bypass IP validation and direct server-side requests to internal services. This issue is fixed in versions 7.15.2 and 8.10.2.

cve.now Index

16Pcve.now Index 16 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure8/25Specific setups only, reachable over the network
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity7.7/10CVSS 7.7
  • No patch0/5No signal

What would change the score

  • Would score about 66 if added to CISA KEV
  • Would score about 61 if CISA's SSVC rates exploitation active
  • Would score about 23 if CISA's SSVC rates it automatable

What to do

  • Check whether your setup matches what the bug needs.

    Affected when SuiteCRM is at version 7.15.1 or earlier, or 8.10.1 or earlier, where the 7.15.1 SSRF fix is bypassed.
  • Upgrade to a fixed version: 7.15.2, 8.10.2.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • SuiteCRM SuiteCRM

    fixed in 7.15.2; From 8.0.0 · fixed in 8.10.2

Evidence 5

  1. Advisory
  2. Repository
  3. Repository
  4. Repository
  5. Repository

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-61649

Is CVE-2026-61649 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

A check meant to block server-side requests to the application's own host uses a substring match, so a crafted request can get past it. This lets an attacker direct server-side requests to internal services. The advisory says it may allow an attacker to compromise the application.Source: github.com

Which versions are affected by CVE-2026-61649?

SuiteCRM: before 7.15.2; from 8.0.0 before 8.10.2.Source: cve.now feed data

Am I affected, and how do I check?

Versions 7.15.1 and earlier, and 8.0.0 through 8.10.1, are affected, because the earlier 7.15.1 fix for GHSA-x3p2-qcqh-qx2m can be bypassed. Compare the installed SuiteCRM version with these ranges to see which release is in use.Source: github.com

How do I fix CVE-2026-61649?

Upgrade to 7.15.2 or 8.10.2, depending on the release line in use. The advisory lists no workaround.Source: github.com