Gitea before 1.27.1 allows remote code execution via the diffpatch API through Git hook installation.
Gitea versions from 1.17 up to but not including 1.27.1 are affected through the diffpatch feature. Fixed in 1.27.1. No vendor severity rating is given, so the CVSS score of 9.8 (critical) applies.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Actively exploited
- Fix
- Fixed in 1.27.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Gitea, a self-hosted Git service, is affected by this vulnerability. An attacker could exploit it to run arbitrary code on the server by abusing the diffpatch API to install Git hooks.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
Gitea before 1.27.1 allows remote code execution via the diffpatch API through Git hook installation.
Timeline
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- CVE published
- CISA remediation deadline
Due date for US federal agencies to patch
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- Gitea Gitea
From 1.17 · fixed in 1.27.1
- code.gitea.io/giteaGo
From 1.17.0
- gitea.devGo
fixed in 1.27.1
- gitea.devGo
From 1.17.0 · fixed in 1.27.1
References 4
blog.gitea.com
GitHub · go-gitea/gitea
runzero.com
GitHub · 0xBlackash/CVE-2026-60004
Questions about CVE-2026-60004
What does this mean?
The diffpatch feature in Gitea can be abused to run arbitrary shell commands as the Gitea operating system user, through installation of Git hooks. This gives remote code execution.Source: github.com, runzero.com, blog.gitea.com
Am I affected, and how do I check?
Gitea versions from 1.17 up to but not including 1.27.1 are affected, and the vulnerable code path is the diffpatch feature. To check a installation, look at the Gitea version shown on the admin dashboard or run the gitea binary with the --version flag.Source: github.com, runzero.com, blog.gitea.com
What should I do about it?
Upgrade to Gitea 1.27.1, which is the fixed version.Source: github.com, runzero.com, blog.gitea.com
Is it being exploited?
Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-08-25, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data