Skip to main content
← All vulnerabilities
CVE-2026-59310

vCenter directory-traversal vulnerability

Affects vCenter's Syslog server component in the 9.1.x.x, 9.0.x.x and 8.0 lines. Fixed in 9.1.0.0300, 9.0.2.0100 and 8.0 U3k. No vendor severity rating is given.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 9.1.0.0300, 9.0.2.0100, 8.0 U3k
None on Exploit-DB, Metasploit or GitHub

Summary

VMware vCenter Server is affected, specifically its built-in Syslog service. An attacker who can reach vCenter over the network could exploit a directory traversal flaw in this service to run arbitrary code on the system.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

VMware vCenter contains a directory traversal vulnerability in the Syslog server. A malicious actor with network access to vCenter may exploit this issue to execute arbitrary code.

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated

Affected versions

  • VMware Cloud Foundation

    9.1.x.x, 9.0.x.x, 5.x

  • VMware vSphere Foundation

    9.1.x.x, 9.0.x.x

  • VMware vCenter

    From 9.1.x.x · fixed in 9.1.0.0300; From 9.0.x.x · fixed in 9.0.2.0100; From 8.0 · fixed in 8.0 U3k

  • VMware Telco Cloud Infrastructure

    3.0

  • VMware Telco Cloud Platform

    5.1.x, 5.0.x, 4.x, 3.0

References 1

support.broadcom.com

FAQ

Questions about CVE-2026-59310

What does this mean?

The Syslog server in vCenter has a directory traversal flaw, which means a crafted path can reach files outside the intended directory. The vendor says this may be used to execute arbitrary code on vCenter.Source: support.broadcom.com

Am I affected, and how do I check?

Affected vCenter builds are 9.1.x.x before 9.1.0.0300, 9.0.x.x before 9.0.2.0100, and 8.0 before 8.0 U3k. Check the vCenter version and build number against these ranges. The facts list Cloud Foundation, vSphere Foundation, Telco Cloud Infrastructure and Telco Cloud Platform without version ranges.Source: support.broadcom.com

What should I do about it?

Upgrade vCenter to the fixed build for its release line: 9.1.0.0300, 9.0.2.0100, or 8.0 U3k.Source: support.broadcom.com

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-08-18, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data