DataGerry < 3.3.0 SSTI via DocAPI Template Rendering
Affects DataGerry versions before 3.3.0 for accounts holding the base.docapi.template.add permission. Fixed in DataGerry 3.3.0.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 3.3.0
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. DataGerry versions before 3.3.0 Attacker is authenticated and holds the base.docapi.template.add permission A user must call the template render endpoint for the payload to be rendered
- Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
- Exposure8/25Specific setups only, reachable over the network
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity8.7/10CVSS 8.7
- No patch0/5No signal
What would change the score
- Would score about 67 if added to CISA KEV
- Would score about 62 if CISA's SSVC rates exploitation active
- Would score about 24 if CISA's SSVC rates it automatable
CVE-2026-57853 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.7 (high) and affects DataGerry; fixed in 3.3.0.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 17/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 3.3.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
DataGerry, before version 3.3.0, has a server-side template injection flaw that lets an attacker who has been granted template-adding permission run arbitrary operating system commands on the server, giving them remote code execution. The attacker can reach it remotely over the network and needs low-privilege login, with no user action required.
Read the original description
DataGerry before 3.3.0 contains a server-side template injection vulnerability that allows authenticated attackers with base.docapi.template.add permission to store arbitrary Jinja2 payloads in the template_data field via POST /rest/docapi/template, which is later rendered in a non-sandboxed Jinja2 environment when a user calls GET /rest/docapi/template/<id>/render/<object_id>. Attackers can exploit the standard cycler.init.globals.os gadget chain to execute arbitrary operating system commands as the DataGerry web process user, confirmed as root in default Docker deployments, achieving remote code execution.
What to do
Check whether your setup matches what the bug needs.
DataGerry versions before 3.3.0 Attacker is authenticated and holds the base.docapi.template.add permission A user must call the template render endpoint for the payload to be renderedUpgrade to a fixed version: 3.3.0.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- DataGerry DataGerry
fixed in 3.3.0
Evidence 3
- Patch
- Link
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-57853
Is CVE-2026-57853 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
DocAPI template rendering does not safely handle template input, so a template can inject server-side code. Through this flaw, an authenticated user with the template-add permission can run arbitrary operating system commands as the DataGerry web process user, which was confirmed as root in default Docker deployments.Source: vulncheck.com
Which versions are affected by CVE-2026-57853?
DataGerry: before 3.3.0.Source: cve.now feed data
Am I affected, and how do I check?
DataGerry versions before 3.3.0 are affected. The flaw needs an authenticated account with the base.docapi.template.add permission, and the payload only renders when a user calls GET /rest/docapi/template/<id>/render/<object_id>. Check the installed DataGerry version and the permissions assigned to accounts to see which setups match.Source: vulncheck.com
How do I fix CVE-2026-57853?
Upgrade DataGerry to version 3.3.0 or later, which contains the fix.Source: vulncheck.com