WordPress WP Customer Area plugin <= 8.4.1 - Cross Site Scripting (XSS) vulnerability
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 8.4.2
- Who is exposed
- Specific setups only
Do first: Upgrade to a fixed version: 8.4.2.
- Exploitation0/40No signal
- Exposure12/25Specific setups only, reachable over the network without a login
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity7.1/10CVSS 7.1
- No patch0/5No signal
What would change the score
- Would score about 69 if added to CISA KEV
- Would score about 64 if CISA's SSVC rates exploitation active
CVE-2026-57666 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.1 (high) and affects WP Customer Area; fixed in 8.4.2.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- FIRST's estimate of the chance attackers exploit it in the next 30 days, updated daily.What do these mean? →
- 0.15% · 3rd percentile
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 19/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 8.4.2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: partial
Summary
The WP Customer Area plugin for WordPress, made by Aguila Technologies and covering all versions up to and including 8.4.1, contains a reflected cross-site scripting flaw. An attacker can reach it remotely without logging in, but a victim must take an action, such as opening a crafted link, before the attacker's script runs in their browser.
Read the original description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Aguila Technologies WP Customer Area customer-area allows Reflected XSS.This issue affects WP Customer Area: from n/a through 8.4.1.
What to do
Upgrade to a fixed version: 8.4.2.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: partial
- Record last updated
Affected versions
- customer-area
through 8.4.1
Evidence 1
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-57666
Is CVE-2026-57666 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
The plugin fails to clean input properly, so an attacker can inject malicious scripts into pages of the site. Those scripts can steal visitor data or hijack visitor accounts.Source: patchstack.com, cve.org
Which versions are affected by CVE-2026-57666?
customer-area: through 8.4.1.Source: cve.now feed data
Am I affected, and how do I check?
WP Customer Area by Aguila Technologies, all versions up to and including 8.4.1. To check, look at the plugin version shown on the WordPress Plugins screen or in the plugin's header in the installed files.Source: patchstack.com, cve.org
How do I fix CVE-2026-57666?
Update the WP Customer Area plugin to version 8.4.2 or later, which contains the fix.Source: patchstack.com, cve.org