OPNsense: Configuration line injection via multiple GUI text fields
Affects OPNsense versions up to and including 26.1.10 and 26.4.1 where Dnsmasq DNS & DHCP is enabled. The listed fix is 26.1.11. The vendor rating is not given, so the CVSS score of 8.1 (high) is the only rating shown.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 26.1.11
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. OPNsense versions up to and including 26.1.10 and 26.4.1 are affected. Dnsmasq DNS & DHCP is enabled. The attacker needs a Web UI or API account with access to the Dnsmasq settings.
- Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
- Exposure8/25Specific setups only, reachable over the network
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity8.1/10CVSS 8.1
- No patch0/5No signal
What would change the score
- Would score about 66 if added to CISA KEV
- Would score about 61 if CISA's SSVC rates exploitation active
- Would score about 23 if CISA's SSVC rates it automatable
CVE-2026-57154 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.1 (high) and affects core; fixed in 26.1.11.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 16/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 26.1.11
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
OPNsense, a FreeBSD-based firewall and routing platform, is affected by a flaw where authenticated users with delegated web UI or API access can inject extra lines into generated service configuration files, such as Dnsmasq, Monit, and OpenVPN. This can alter privileged service behavior beyond the permissions granted, cross access-control boundaries, or cause denial of service.
Read the original description
OPNsense is a FreeBSD based firewall and routing platform. Prior to 26.1.11 and 26.4.1p1, authenticated Web UI or API users with delegated access to affected settings can submit CR or LF characters in fields expected to contain one line, causing generated privileged service configuration files to contain additional attacker-controlled directives or policy lines. The confirmed Dnsmasq path includes dhcp_boot.filename, dhcp_boot.servername, dhcp_boot.address, and dhcp_options.value, which are rendered into /usr/local/etc/dnsmasq.conf; access through page-services-dnsforwarder covers api/dnsmasq/*. Related affected fields span OpenVPN, DHCPv6, Unbound, IPsec, NTP, PPP or MPD, Monit, firewall, sudo, WebGUI, and System General configuration. Applying or restarting the affected service can alter behavior beyond the delegated setting, create service-side files, cross RBAC boundaries, or cause denial of service. Line injection through Monit mail password and adjacent Monit text fields into /usr/local/etc/monitrc demonstrated root command execution. Arbitrary shell command execution was not confirmed for the Dnsmasq path. This issue is fixed in versions 26.1.11 and 26.4.1p1.
What to do
Check whether your setup matches what the bug needs.
OPNsense versions up to and including 26.1.10 and 26.4.1 are affected. Dnsmasq DNS & DHCP is enabled. The attacker needs a Web UI or API account with access to the Dnsmasq settings.Upgrade to a fixed version: 26.1.11.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- opnsense core
fixed in 26.1.11
Evidence 3
- Advisory
- Repository
- Repository
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-57154
Is CVE-2026-57154 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
Several text fields in the OPNsense web interface can be used to insert extra lines into the generated configuration. The issue requires an account with access to the Dnsmasq settings.Source: github.com
Which versions are affected by CVE-2026-57154?
core: before 26.1.11.Source: cve.now feed data
Am I affected, and how do I check?
Versions up to and including 26.1.10 and 26.4.1 are listed as affected, when Dnsmasq DNS & DHCP is enabled. Check the installed version in the web interface and whether Dnsmasq DNS & DHCP is enabled under the services settings.Source: github.com
How do I fix CVE-2026-57154?
Upgrade to OPNsense 26.1.11, which is the listed fixed version.Source: github.com