Skip to main content
← Vulnerabilities

WAMR fast interpreter loader heap buffer overflow via constant deduplication mismatch

Affects WAMR 2.4.4 and earlier builds with the fast interpreter enabled (WAMR_BUILD_FAST_INTERP=1, the default mode). Fixed in 2.4.5.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

8.8HighCNA
Exploited
Proof of concept public, per CISA
Fix
Fixed in 2.4.5
Who is exposed
Default setups

Do first: Check every install: default setups are affected.

Published
Last modified
47/100 · provisional
Default setups
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: total

Summary

WAMR (WebAssembly Micro Runtime), a lightweight WebAssembly runtime, is affected by a heap buffer overflow in its fast interpreter loader, which only occurs in builds with the fast interpreter enabled. A remote attacker without logging in can supply a crafted WebAssembly module that writes data past a heap buffer during loading, which can corrupt heap metadata and crash the process, causing denial of service.

Read the original description

WebAssembly Micro Runtime (WAMR) is a lightweight standalone WebAssembly (Wasm) runtime. Prior to 2.4.5, the two-pass fast interpreter loader in core/iwasm/interpreter/wasm_loader.c can make inconsistent constant-table decisions between the sizing pass and the emitting pass. After duplicate constants inflate the first pass beyond the constant-slot limit, wasm_loader_get_const_offset emits later constants inline, but the between-pass sort and deduplication reduces the table so the second pass can choose table references and cause reserve_block_ret to emit additional copy operands that were not included in code_compiled_peak_size. A crafted module can therefore make the second pass write partially attacker-controlled compiled-code data beyond the heap buffer allocated from the first pass's size calculation during wasm_runtime_load, before guest code executes. This can corrupt host heap metadata and deterministically crash the process, causing denial of service; further consequences depend on the host application's heap layout. Builds using WAMR_BUILD_FAST_INTERP=1 are affected; disabling the fast interpreter avoids the vulnerable loader. This issue is fixed in version 2.4.5.

cve.now Index

47Pcve.now Index 47 of 100 · methodology v3 · provisional
  • Exploitation15/40CISA rates a proof of concept as public
  • Exposure22/25Default setups, reachable over the network without a login
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity9.8/10CVSS 8.8, total technical impact per CISA
  • No patch0/5No signal

What would change the score

  • Would score about 72 if added to CISA KEV
  • Would score about 67 if CISA's SSVC rates exploitation active

What to do

  • Check every install: default setups are affected.

  • Upgrade to a fixed version: 2.4.5.

  • Workaround: Disable the fast interpreter at build time (-DWAMR_BUILD_FAST_INTERP=0).

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: total

  4. Record last updated

Affected versions

  • bytecodealliance wasm-micro-runtime

    fixed in 2.4.5

Evidence 4

  1. Advisory
  2. Repository
  3. Repository
  4. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-54912

Is CVE-2026-54912 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. CISA's SSVC assessment notes a proof of concept exists. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

When WAMR loads a WebAssembly module, the fast interpreter's loader can write past the end of a heap buffer while deduplicating constants. This can corrupt heap metadata and crash the host process, causing denial of service. Further consequences depend on the host's heap layout.Source: github.com

Which versions are affected by CVE-2026-54912?

wasm-micro-runtime: before 2.4.5.Source: cve.now feed data

Am I affected, and how do I check?

Builds with WAMR_BUILD_FAST_INTERP=1, the default interpreter mode, on version 2.4.4 and earlier, including the main branch at commit dd0fee27. Prior versions with the two-pass fast interpreter loader are likely affected too. To check a build, look at its WAMR_BUILD_FAST_INTERP setting and its version.Source: github.com

How do I fix CVE-2026-54912?

Upgrade to WAMR 2.4.5, which contains the fix. If the upgrade is not possible, rebuild with the fast interpreter disabled using -DWAMR_BUILD_FAST_INTERP=0.Source: github.com