Skip to main content
← Vulnerabilities

WordPress WP Customer Area plugin <= 8.4.1 - Cross Site Scripting (XSS) vulnerability

WP Customer Area plugin version 8.4.1 and earlier is affected. The fix is in 8.4.2.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

7.1HighCNA
Exploited
No known exploitation
Fix
Fixed in 8.4.2
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. WP Customer Area plugin version 8.4.1 or earlier

19Pcve.now Index 19 of 100 · methodology v3 · provisional
  • Exploitation0/40No signal
  • Exposure12/25Specific setups only, reachable over the network without a login
  • Reach?/20Reach: unknown (data gap). No tracked technology or package matched
  • Severity7.1/10CVSS 7.1
  • No patch0/5No signal

What would change the score

  • Would score about 69 if added to CISA KEV
  • Would score about 64 if CISA's SSVC rates exploitation active

CVE-2026-54861 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.1 (high) and affects WP Customer Area; fixed in 8.4.2.

Published
Last modified
Published
Not listed in CISA KEV
0.15% · 3rd percentile
19/100 · provisional
Specific setups only
Fix
Fixed in 8.4.2
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

The WP Customer Area plugin for WordPress, made by Aguila Technologies, contains a reflected cross-site scripting flaw in versions up to and including 8.4.1. An attacker can reach it remotely without logging in, but a victim must be tricked into clicking a crafted link, and the bug can then run attacker-supplied script in the victim's browser.

Read the original description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Aguila Technologies WP Customer Area customer-area allows Reflected XSS.This issue affects WP Customer Area: from n/a through 8.4.1.

What to do

  • Check whether your setup matches what the bug needs.

    WP Customer Area plugin version 8.4.1 or earlier
  • Upgrade to a fixed version: 8.4.2.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  4. Record last updated

Affected versions

  • customer-area

    through 8.4.1

Evidence 1

  1. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-54861

Is CVE-2026-54861 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

The plugin fails to properly sanitize some input, which lets an attacker inject malicious scripts into pages of the site. Those scripts can steal visitor data or hijack visitor accounts.Source: patchstack.com, cve.org

Which versions are affected by CVE-2026-54861?

customer-area: through 8.4.1.Source: cve.now feed data

Am I affected, and how do I check?

Versions of the WP Customer Area WordPress plugin up to and including 8.4.1 are affected, with no known earliest version. To check, look at the plugin version shown on the Plugins screen in the WordPress admin dashboard.Source: patchstack.com, cve.org

How do I fix CVE-2026-54861?

Update the WP Customer Area plugin to version 8.4.2 or later.Source: patchstack.com, cve.org