Skip to main content
← All vulnerabilities
CVE-2026-54855

WordPress Profile Builder plugin <= 4.0.5 - Cross Site Scripting (XSS) vulnerability

Affects the WordPress Profile Builder plugin, version 4.0.5 and earlier. Fixed in 4.0.6. No vendor severity rating is given, only the CVSS score of 7.1.

Published
Last modified
published
Not listed in CISA KEV
Specific setups only
Fix
Fixed in 4.0.6
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Unauthenticated Cross Site Scripting (XSS) in Profile Builder <= 4.0.5 versions.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  4. Record last updated

Affected versions

  • profile-builder

    through 4.0.5

References 1

patchstack.com

FAQ

Questions about CVE-2026-54855

What does this mean?

This is a cross-site scripting flaw, which lets attackers inject malicious scripts into the site. The scripts can steal visitor data or hijack visitor accounts.Source: patchstack.com

Am I affected, and how do I check?

Profile Builder plugin version 4.0.5 and earlier are listed as vulnerable. To check a site, look up the installed version of Profile Builder on the Plugins screen of the WordPress admin.Source: patchstack.com

What should I do about it?

Update the Profile Builder plugin to version 4.0.6 or later.Source: patchstack.com

Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data