Skip to main content
← Vulnerabilities

WordPress Contact Form by WPForms plugin <= 2.0.3 - Cross Site Scripting (XSS) vulnerability

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

7.1HighCNA
Exploited
No known exploitation
Fix
Fixed in 2.0.3.1
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. WordPress Contact Form by WPForms plugin version 2.0.3 or earlier (wpforms-lite)

19Pcve.now Index 19 of 100 · methodology v3 · provisional
  • Exploitation0/40No signal
  • Exposure12/25Specific setups only, reachable over the network without a login
  • Reach?/20Reach: unknown (data gap). No tracked technology or package matched
  • Severity7.1/10CVSS 7.1
  • No patch0/5No signal

What would change the score

  • Would score about 69 if added to CISA KEV
  • Would score about 64 if CISA's SSVC rates exploitation active

CVE-2026-54851 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.1 (high) and affects Contact Form by WPForms; fixed in 2.0.3.1.

Published
Last modified
Published
Not listed in CISA KEV
0.15% · 3rd percentile
19/100 · provisional
Specific setups only
Fix
Fixed in 2.0.3.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

The Contact Form by WPForms WordPress plugin has a reflected cross-site scripting flaw that lets an attacker run malicious scripts in a victim's browser. An attacker can reach it remotely without logging in, but a user must first interact with a crafted request or link.

Read the original description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Awesomemotive Contact Form by WPForms wpforms-lite allows Reflected XSS.This issue affects Contact Form by WPForms: from n/a through 2.0.3.

What to do

  • Check whether your setup matches what the bug needs.

    WordPress Contact Form by WPForms plugin version 2.0.3 or earlier (wpforms-lite)
  • Upgrade to a fixed version: 2.0.3.1.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  4. Record last updated

Affected versions

  • wpforms-lite

    through 2.0.3

Evidence 1

  1. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-54851

Is CVE-2026-54851 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

The plugin fails to properly sanitize some input, which lets an attacker inject malicious scripts into pages of the site. Those scripts can run in visitors' browsers and steal visitor data or hijack their accounts.Source: patchstack.com, cve.org

Which versions are affected by CVE-2026-54851?

wpforms-lite: through 2.0.3.Source: cve.now feed data

Am I affected, and how do I check?

Versions of the WPForms Lite plugin (wpforms-lite, sold as Contact Form by WPForms) up to and including 2.0.3 are listed as vulnerable. To check, open the Plugins screen in WordPress admin and read the version shown next to Contact Form by WPForms.Source: patchstack.com, cve.org

How do I fix CVE-2026-54851?

Update the plugin to the latest available version, at least 2.0.3.1, as the vendor advises.Source: patchstack.com, cve.org