Skip to main content
← All vulnerabilities
CVE-2026-48172

LiteSpeed User-End cPanel Plugin before 2.4.5 allows privilege escalation (possibly to root), as exploited in the wild in May 2026.

Affects LiteSpeed User-End cPanel Plugin versions 2.3 through 2.4.4, where a cPanel user can gain root privileges. The vendor gives no separate rating. Fixed in cPanel Plugin 2.4.7.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 2.4.7, 5.3.1.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: active
  • Automatable: yes
  • Technical impact: total

Summary

The LiteSpeed User-End plugin for cPanel, which is used to manage LiteSpeed caching features on cPanel hosting servers, contains a flaw in how it handles enabling and disabling Redis, and this flaw can let a local user gain elevated privileges, possibly full administrative (root) control of the server.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

LiteSpeed User-End cPanel Plugin before 2.4.5 allows privilege escalation (possibly to root), as exploited in the wild in May 2026. Detection is best done via a command line of grep -rE "cpanel_jsonapi_func=redisAble" /var/cpanel/logs /usr/local/cpanel/logs/ 2>/dev/null in Bash. If you get no output, you have not been hit with exploitation of the vulnerability. If there is output, we recommend you examine the IP addresses in the list, determine if they are valid IP addresses, and if not, block them. To determine damage done, examine the system logs for use by the detected IP addresses. The issue is related to mishandling of Redis enable/disable features. The recommended minimum version is 2.4.7.

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA SSVC assessment

    Exploitation: active · Automatable: yes · Technical impact: total

  4. CISA remediation deadline

    Due date for US federal agencies to patch

  5. Record last updated
  6. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • WHM Plugin/cPanel Plugin

    From 2.3 · fixed in 2.4.7

  • WHM Plugin/cPanel Plugin

    fixed in 5.3.1.0

References 3

litespeedtech.com

blog.litespeedtech.com

FAQ

Questions about CVE-2026-48172

What does this mean?

The lsws.redisAble function in the LiteSpeed User-End cPanel plugin lets a cPanel user run arbitrary scripts as root. This is a privilege escalation from a normal cPanel account to root.Source: blog.litespeedtech.com

Am I affected, and how do I check?

User-end LiteSpeed cPanel plugin versions from 2.3 up to 2.4.4 are affected. To check, compare the installed version of the LiteSpeed User-End cPanel plugin against that range.Source: blog.litespeedtech.com

What should I do about it?

Upgrade the LiteSpeed user-end plugin for cPanel to 2.4.7 or later, or upgrade to LiteSpeed WHM Plugin 5.3.1.0 or later, which bundles cPanel plugin 2.4.7.Source: blog.litespeedtech.com

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-05-26, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data