GLPI: Blind Time based SQLI in dropdowns
Affects GLPI 9.4.0 up to 10.0.26 and 11.0.0 up to 11.0.8, where any logged-in user can reach a time-based SQL injection through the dropdown values endpoint. Fixed in 10.0.26 and 11.0.8.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 10.0.26, 11.0.8
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. Affected GLPI versions are 9.4.0 up to but not including 11.0.0, and 11.0.0 and later up to the fixed releases.
- Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
- Exposure8/25Specific setups only, reachable over the network
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity8.7/10CVSS 8.7
- No patch0/5No signal
What would change the score
- Would score about 67 if added to CISA KEV
- Would score about 62 if CISA's SSVC rates exploitation active
- Would score about 24 if CISA's SSVC rates it automatable
CVE-2026-47678 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.7 (high) and affects glpi; fixed in 10.0.26 and 11.0.8.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 17/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 10.0.26, 11.0.8
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
GLPI, a free asset and IT management software package, contains a SQL injection flaw in its dropdown values endpoint that can be reached remotely by any logged-in user. An attacker with a standard account can use it to read or change data in the database and disrupt the application's backend.
Read the original description
GLPI is a free asset and IT management software package. From 9.4.0 until 10.0.26 and 11.0.8, any authenticated user can submit crafted values to the dropdown values fetching endpoint that are incorporated into a database query. This permits SQL injection through the dropdown endpoint. This issue is fixed in versions 11.0.8 and 10.0.26.
What to do
Check whether your setup matches what the bug needs.
Affected GLPI versions are 9.4.0 up to but not including 11.0.0, and 11.0.0 and later up to the fixed releases.Upgrade to a fixed version: 10.0.26, 11.0.8.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- glpi-project glpi
From 9.4.0 · fixed in 10.0.26; From 11.0.0 · fixed in 11.0.8
Evidence 5
- Advisory
- Repository
- Repository
- Repository
- Repository
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-47678
Is CVE-2026-47678 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
The dropdown values endpoint in GLPI does not properly handle user input before it is used in a database query. A logged-in user can craft a request that makes the database run injected SQL, and the response timing reveals the results, which is a blind, time-based form of SQL injection. The impact is rated high for confidentiality, integrity and availability.Source: github.com
Which versions are affected by CVE-2026-47678?
glpi: from 9.4.0 before 10.0.26; from 11.0.0 before 11.0.8.Source: cve.now feed data
Am I affected, and how do I check?
Versions 9.4.0 up to but not including 11.0.0, and 11.0.0 and later up to 11.0.8, are affected. To check, look at the GLPI version shown in the footer of the web interface or run the version check on the server, then compare it against the fixed releases 10.0.26 and 11.0.8.Source: github.com
How do I fix CVE-2026-47678?
Upgrade to GLPI 10.0.26 if you are on the 10.0 line, or to 11.0.8 if you are on the 11.0 line. No workaround is listed in the facts, so the upgrade is the fix.Source: github.com