Skip to main content
← All vulnerabilities
CVE-2026-43414

scsi: qla2xxx: Completely fix fcport double free

Affects Linux kernel releases in several stable branches, such as 6.1.84 up to 6.1.191, that use the qla2xxx SCSI driver. Fixed in 6.1.191, 6.6.160, and later stable releases in each branch.

Published
Last modified
published
Not listed in CISA KEV
Unclear
Fix
Fixed in 6.1.191, 6.6.160, 5.16, 6.8, 6.9, and 3 more
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: total

Summary

The Linux kernel's SCSI driver for QLogic Fibre Channel host adapters (qla2xxx) is affected, where a port structure could be freed twice during an error path in ELS command handling. The result is memory corruption that can lead to a crash or instability of the system.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

In the Linux kernel, the following vulnerability has been resolved: scsi: qla2xxx: Completely fix fcport double free In qla24xx_els_dcmd_iocb() sp->free is set to qla2x00_els_dcmd_sp_free(). When an error happens, this function is called by qla2x00_sp_release(), when kref_put() releases the first and the last reference. qla2x00_els_dcmd_sp_free() frees fcport by calling qla2x00_free_fcport(). Doing it one more time after kref_put() is a bad idea.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: total

  3. Record last updated

Affected versions

  • Linux Linux

    From 6.1.84 · fixed in 6.1.191; From 6.6.24 · fixed in 6.6.160; From 5.15.154 · fixed in 5.16; From 6.7.12 · fixed in 6.8; From 6.8.3 · fixed in 6.9

  • Linux Linux

    6.9

  • KernelLinux

    fixed in 6.6.160; From 6.7.0 · fixed in 6.12.114; From 6.9.0 · fixed in 6.18.57; From 6.13.0 · fixed in 6.19.9

References 6

git.kernel.org

FAQ

Questions about CVE-2026-43414

What does this mean?

The qla2xxx SCSI driver can free an fcport structure twice. The double free happens in the ELS command error path, where error handling releases the command reference.Source: git.kernel.org

Am I affected, and how do I check?

The affected range covers Linux kernel versions from 6.1.84, 6.6.24, 5.15.154, 6.7.12, and 6.8.3 up to the fixed releases listed for each branch. To check a system, run uname -r to see the kernel version and lsmod | grep qla2xxx to see whether the qla2xxx driver is loaded.Source: git.kernel.org

What should I do about it?

Upgrade to a kernel release that includes the fix, such as 6.1.191, 6.6.160, 6.12.114, 6.18.57, or 6.19.9, depending on your branch. Use the stable release for your series where one is listed.Source: git.kernel.org

Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data