Skip to main content
← All vulnerabilities
CVE-2026-43042

mpls: add seqcount to protect the platform_label{,s} pair

Affects Linux kernel MPLS code in 4.1.0 up to 6.6.160, 6.7.0 up to 6.12.114, and 6.13.0 up to 6.19.12. No vendor rating is given, and the facts list no fix.

Published
Last modified
published
Not listed in CISA KEV
Specific setups only
Fix
Fixed in 6.6.160, 6.12.114, 6.19.12
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

In the Linux kernel, the following vulnerability has been resolved: mpls: add seqcount to protect the platform_label{,s} pair The RCU-protected codepaths (mpls_forward, mpls_dump_routes) can have an inconsistent view of platform_labels vs platform_label in case of a concurrent resize (resize_platform_label_table, under platform_mutex). This can lead to OOB accesses. This patch adds a seqcount, so that we get a consistent snapshot. Note that mpls_label_ok is also susceptible to this, so the check against RTA_DST in rtm_to_route_config, done outside platform_mutex, is not sufficient. This value gets passed to mpls_label_ok once more in both mpls_route_add and mpls_route_del, so there is no issue, but that additional check must not be removed.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Linux Linux

    Version range not reported

  • Linux Linux

    4.1

  • KernelLinux

    From 4.1.0 · fixed in 6.6.160; From 6.7.0 · fixed in 6.12.114; From 6.13.0 · fixed in 6.19.12

References 5

git.kernel.org

FAQ

Questions about CVE-2026-43042

What does this mean?

The MPLS platform label table can be resized while RCU-protected code is reading it. The reader can then see a platform_labels count that does not match the platform_label array, which causes out-of-bounds memory accesses.Source: git.kernel.org

Am I affected, and how do I check?

Kernels in the ranges 4.1.0 to before 6.6.160, 6.7.0 to before 6.12.114, and 6.13.0 to before 6.19.12. To check a system, compare the output of uname -r against these ranges. The bug needs a concurrent resize of the MPLS platform label table while RCU-protected code runs.Source: git.kernel.org

What should I do about it?

Move to a kernel at or past the fixed version for your branch: 6.6.160, 6.12.114, or 6.19.12.Source: git.kernel.org

Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data