Skip to main content
← All vulnerabilities
CVE-2026-42208PYSEC-2026-391GHSA-R75F-5X8P-QVMC

LiteLLM: SQL injection in Proxy API key verification

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 1.83.7
None on Exploit-DB, Metasploit or GitHub

Summary

LiteLLM, an open-source proxy server that routes calls to LLM APIs in OpenAI-compatible format, is affected by this vulnerability. An unauthenticated attacker could exploit it to read, and possibly modify, data in the proxy's database, potentially gaining unauthorized access to the credentials the proxy manages.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.81.16 to before version 1.83.7, a database query used during proxy API key checks mixed the caller-supplied key value into the query text instead of passing it as a separate parameter. An unauthenticated attacker could send a specially crafted Authorization header to any LLM API route (for example POST /chat/completions) and reach this query through the proxy's error-handling path. An attacker could read data from the proxy's database and may be able to modify it, leading to unauthorised access to the proxy and the credentials it manages. This issue has been patched in version 1.83.7.

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated
  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • BerriAI litellm

    From 1.81.16 · fixed in 1.83.7

  • litellmPyPI

    From 1.81.16 · fixed in 1.83.7

References 2

GitHub · BerriAI/litellm

FAQ

Questions about CVE-2026-42208

What does this mean?

A flaw in how LiteLLM Proxy checks API keys lets crafted input reach a database query without proper sanitisation, so an attacker could read data from the proxy's database and may be able to modify it. That can expose the proxy and the credentials it manages.Source: github.com

Am I affected, and how do I check?

LiteLLM proxy versions from 1.81.16 up to, but not including, 1.83.7 are affected. The issue is reached through the proxy's error-handling path, so check your installed LiteLLM version and whether your proxy uses that path.Source: github.com

What should I do about it?

Upgrade LiteLLM to 1.83.7 or later, which contains the fix.Source: github.com

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-05-08, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data