GeoNetwork: Reflected XSS through client-side template injection
Affects GeoNetwork 3.0.0 through 3.12.12, 4.0.0-alpha.1 through 4.0.6, 4.2.0 through 4.2.14, and 4.4.0 before 4.4.10. Fixed in 4.2.15 and 4.4.10.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 4.2.15, 4.4.10
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. Affected GeoNetwork versions include 4.2.0 through 4.2.14 (other affected ranges also listed). A service URL is requested that does not exist or that the user is not authorized to access, so GeoNetwork shows an error page.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 19/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 4.2.15, 4.4.10
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
GeoNetwork, a catalog application for managing spatially referenced resources, is affected from version 3.0.0 through 4.2.15 and 4.4.10 (exclusive of the fixed releases). An attacker who tricks a user, including an administrator, into opening a crafted link can run malicious scripts in the victim's logged-in browser session, allowing information theft or actions performed as that user.
Read the original description
GeoNetwork is a catalog application to manage spatially referenced resources. From 3.0.0 until 4.2.15 and 4.4.10, requesting a nonexistent or unauthorized service URL can cause an error page to reflect attacker-controlled request content inside an AngularJS application without adequately neutralizing it for template evaluation. A remote attacker can induce a victim, including an administrator, to open a crafted link so the reflected value is evaluated as an AngularJS template expression. Combined with known AngularJS sandbox-escape techniques, this can execute arbitrary JavaScript in the victim's authenticated browser session, disclose information, or perform actions as the victim. This issue is fixed in versions 4.2.15 and 4.4.10.
What to do
Check whether your setup matches what the bug needs.
Affected GeoNetwork versions include 4.2.0 through 4.2.14 (other affected ranges also listed). A service URL is requested that does not exist or that the user is not authorized to access, so GeoNetwork shows an error page.Upgrade to a fixed version: 4.2.15, 4.4.10.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- geonetwork core-geonetwork
From 3.0.0 · through 3.12.12; From 4.0.0-alpha.1 · through 4.0.6; From 4.2.0 · fixed in 4.2.15; From 4.4.0 · fixed in 4.4.10
Evidence 5
- Advisory
- Repository
- Repository
- Repository
- Repository
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-39379
What does this mean?
A GeoNetwork error page for a service URL that does not exist or that the user is not authorized to access can run injected JavaScript in the victim's authenticated session. That script can be used to exfiltrate information or perform actions as the victim.Source: github.com
Am I affected, and how do I check?
The advisory lists affected versions 3.0.0 through 3.12.12, 4.0.0-alpha.1 through 4.0.6, 4.2.0 through 4.2.14, and 4.4.0 before 4.4.10. To check a installation, look at the GeoNetwork version shown in the application or its build information.Source: github.com
What should I do about it?
Upgrade to a supported release: 4.2.15 or later, or 4.4.10 or later. The sources list no workaround for this issue.Source: github.com
Is it being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data