Skip to main content
← All vulnerabilities
CVE-2026-33017PYSEC-2026-379GHSA-VWMF-PQ79-VJVX

Langflow has Unauthenticated Remote Code Execution via Public Flow Build Endpoint

Affects Langflow before 1.9.0 on instances with at least one public flow. No vendor rating is given beyond the CVSS score of 9.3. Fixed in 1.9.0.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 1.9.0
None on Exploit-DB, Metasploit or GitHub

Summary

Langflow, a tool for building and deploying AI-powered agents and workflows, is affected. An unauthenticated attacker can run arbitrary code on the server through a public flow build endpoint, which could give them full control over the affected system.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

Langflow is a tool for building and deploying AI-powered agents and workflows. In versions prior to 1.9.0, the POST /api/v1/build_public_tmp/{flow_id}/flow endpoint allows building public flows without requiring authentication. When the optional data parameter is supplied, the endpoint uses attacker-controlled flow data (containing arbitrary Python code in node definitions) instead of the stored flow data from the database. This code is passed to exec() with zero sandboxing, resulting in unauthenticated remote code execution. This is distinct from CVE-2025-3248, which fixed /api/v1/validate/code by adding authentication. The build_public_tmp endpoint is designed to be unauthenticated (for public flows) but incorrectly accepts attacker-supplied flow data containing arbitrary executable code. This issue has been fixed in version 1.9.0.

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated
  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • langflow-ai langflow

    fixed in 1.9.0

  • langflowPyPI

    fixed in 1.9.0

References 3

GitHub · langflow-ai/langflow

GitHub Advisory Database

FAQ

Questions about CVE-2026-33017

What does this mean?

The flaw lets an unauthenticated remote party run code on the Langflow server through the public flow build endpoint, with the full privileges of the server process. The attacker must know the UUID of a public flow.Source: github.com

Am I affected, and how do I check?

Langflow versions before 1.9.0 are affected, but only on instances that have at least one public flow. To check, look at the installed Langflow version and whether any flow on the instance is public.Source: github.com

What should I do about it?

Upgrade Langflow to version 1.9.0 or later, which is the fixed release listed for this vulnerability.Source: github.com

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-03-25, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data