Skip to main content
← All vulnerabilities
CVE-2026-31675

net/sched: sch_netem: fix out-of-bounds access in packet corruption

Affects Linux kernel builds using netem packet corruption with fully non-linear AF_PACKET TX_RING packets over an IPIP tunnel. Fixed in 6.6.134, 6.12.81, 6.18.22 and 6.19.12 depending on branch.

Published
Last modified
published
Not listed in CISA KEV
Specific setups only
Fix
Fixed in 6.6.134, 6.12.81, 6.18.22, 6.19.12
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

In the Linux kernel, the following vulnerability has been resolved: net/sched: sch_netem: fix out-of-bounds access in packet corruption In netem_enqueue(), the packet corruption logic uses get_random_u32_below(skb_headlen(skb)) to select an index for modifying skb->data. When an AF_PACKET TX_RING sends fully non-linear packets over an IPIP tunnel, skb_headlen(skb) evaluates to 0. Passing 0 to get_random_u32_below() takes the variable-ceil slow path which returns an unconstrained 32-bit random integer. Using this unconstrained value as an offset into skb->data results in an out-of-bounds memory access. Fix this by verifying skb_headlen(skb) is non-zero before attempting to corrupt the linear data area. Fully non-linear packets will silently bypass the corruption logic.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • Linux Linux

    Version range not reported

  • Linux Linux

    2.6.16

  • KernelLinux

    From 2.6.16 · fixed in 6.6.134; From 6.7.0 · fixed in 6.12.81; From 6.13.0 · fixed in 6.18.22; From 6.19.0 · fixed in 6.19.12

References 6

git.kernel.org

FAQ

Questions about CVE-2026-31675

What does this mean?

The netem packet corruption code can pick a random offset into the packet data without a bounds check, so it can read or write memory outside the buffer. This is an out-of-bounds memory access inside the kernel.Source: git.kernel.org

Am I affected, and how do I check?

Kernels from 2.6.16 up to the fixed release for their branch are in the affected range: before 6.6.134, from 6.7.0 before 6.12.81, from 6.13.0 before 6.18.22, and from 6.19.0 before 6.19.12. Check the running version with uname -r. The bug needs netem packet corruption and fully non-linear packets sent through AF_PACKET TX_RING over an IPIP tunnel.Source: git.kernel.org

What should I do about it?

Upgrade to the fixed kernel for your branch: 6.6.134, 6.12.81, 6.18.22, or 6.19.12 or later.Source: git.kernel.org

Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data