Skip to main content
← Vulnerabilities

SolarWinds Dameware Buffer Overflow Vulnerability

Affects SolarWinds Dameware 2026.3 and all earlier versions. No vendor rating is given. Fixed in Dameware 2026.3.1.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

8.4HighCNA
Exploited
No known exploitation
Fix
Fixed in SolarWinds Dameware 2026.3.1
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Affects SolarWinds Dameware 2026.3 and all previous versions

17Pcve.now Index 17 of 100 · methodology v3 · provisional
  • Exploitation0/40No signal
  • Exposure8/25Specific setups only, reachable over the network
  • Reach?/20Reach: unknown (data gap). No tracked technology or package matched
  • Severity9.4/10CVSS 8.4, total technical impact per CISA
  • No patch0/5No signal

What would change the score

  • Would score about 67 if added to CISA KEV
  • Would score about 62 if CISA's SSVC rates exploitation active
  • Would score about 24 if CISA's SSVC rates it automatable

CVE-2026-28335 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.4 (high) and affects Dameware; fixed in SolarWinds Dameware 2026.3.1.

Published
Last modified
Published
Not listed in CISA KEV
17/100 · provisional
Specific setups only
Fix
Fixed in SolarWinds Dameware 2026.3.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

SolarWinds Dameware, a remote administration software product, is affected by a buffer overflow flaw that can allow an attacker to execute arbitrary code on the system. Exploitation requires the attacker to have valid authentication credentials.

Read the original description

SolarWinds Dameware was found to be affected by a buffer overflow vulnerability that can result in remote code execution. Authentication is required.

What to do

  • Check whether your setup matches what the bug needs.

    Affects SolarWinds Dameware 2026.3 and all previous versions
  • Upgrade to a fixed version: SolarWinds Dameware 2026.3.1.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  4. Record last updated

Affected versions

  • SolarWinds Dameware

    through 2026.3

Evidence 2

  1. Advisory
  2. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-28335

Is CVE-2026-28335 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

A buffer overflow in SolarWinds Dameware can result in remote code execution. The facts provided do not describe the exact input or code path that triggers it.Source: solarwinds.com

Which versions are affected by CVE-2026-28335?

Dameware: through 2026.3.Source: cve.now feed data

Am I affected, and how do I check?

SolarWinds Dameware 2026.3 and all previous versions are affected, as listed in the product range from the first release through 2026.3. To check your version, look at the Dameware version shown in the product's about or version information.Source: solarwinds.com

How do I fix CVE-2026-28335?

Upgrade to SolarWinds Dameware 2026.3.1, which is the fixed version listed in the advisory data.Source: solarwinds.com