Skip to main content
← All vulnerabilities
CVE-2026-22769

Dell RecoverPoint for Virtual Machines, versions prior to 6.0.3.1 HF1, contain a hardcoded credential vulnerability.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 6.0.3.1 HF1
None on Exploit-DB, Metasploit or GitHub

Summary

Dell RecoverPoint for Virtual Machines, an enterprise data protection product, is affected by a hardcoded credential flaw that could let a remote attacker who knows the built-in password gain unauthorized access to the underlying operating system with root-level control.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

Dell RecoverPoint for Virtual Machines, versions prior to 6.0.3.1 HF1, contain a hardcoded credential vulnerability. This is considered critical as an unauthenticated remote attacker with knowledge of the hardcoded credential could potentially exploit this vulnerability leading to unauthorized access to the underlying operating system and root-level persistence. Dell recommends that customers upgrade or apply one of the remediations as soon as possible.

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated
  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • Dell RecoverPoint for Virtual Machines

    From 5.3 SP4 P1 · fixed in 6.0.3.1 HF1

  • Dell RecoverPoint for Virtual Machines

    From 6.0, 6.0 SP1, 6.0 SP1 P1, 6.0 SP1 P2, 6.0 SP2, 6.0 SP2 P1, 6.0 SP3, and 6.0 SP3 P1 · fixed in 6.0.3.1 HF1

References 1

dell.com

FAQ

Questions about CVE-2026-22769

What does this mean?

The product contains a hardcoded credential, a fixed password or key built into the software that cannot be changed by the owner. An attacker who knows it can gain unauthorized access to the underlying operating system and establish root-level persistence.Source: dell.com

Am I affected, and how do I check?

Dell RecoverPoint for Virtual Machines versions prior to 6.0.3.1 HF1 are affected, including 5.3 SP4 P1 and 6.0 through 6.0 SP3 P1. Check the installed version of RecoverPoint for Virtual Machines against this list to see where it stands.Source: dell.com

What should I do about it?

Upgrade to RecoverPoint for Virtual Machines 6.0.3.1 HF1. Where an upgrade cannot be applied immediately, Dell provides a remediation script described in the Knowledge Base article for DSA-2026-079.Source: dell.com

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-02-18, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data