Incomplete patch leads to administrative account takeover
Affects N-central instances through 2026.3 that are not running 2026.3.1. The fix is in build 2026.3.1.7, which the advisory lists as the build number.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Actively exploited
- Fix
- Fixed in 2026.3.1.7
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
N-central, a remote monitoring and management platform, is affected by this vulnerability. An attacker could bypass authentication and take over administrative accounts because a previous fix for the issue was incomplete.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
An incomplete patch for CVE-2026-18556 allows for authentication bypass and account takeover in N-central Versions through 2026.3.1
Timeline
- CVE published
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- Record last updated
- CISA remediation deadline
Due date for US federal agencies to patch
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- N-able N-central
through 2026.3
References 3
documentation.n-able.com
status.n-able.com
cve.org
Questions about CVE-2026-18577
What does this mean?
The advisory title says an incomplete patch leads to administrative account takeover. The available facts do not describe the technical mechanism or the impact in more detail.Source: status.n-able.com
Am I affected, and how do I check?
N-central from the first release through version 2026.3 is affected, covering all instances not running 2026.3.1. To check an installation, look up its N-central version and compare it with 2026.3.1.Source: status.n-able.com
What should I do about it?
Upgrade N-central to build 2026.3.1.7, the fixed build listed in the advisory.Source: status.n-able.com
Is it being exploited?
Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-08-03, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data