IBM Watson Speech Services Cartridge is vulnerable to a D.O.S. in Unpacker.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 5.4.0 Patch 8
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 5.4.0 Patch 8.
- Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
- Exposure17/25No login or user action needed, reachable over the network without a login · Data gap: Advisories don't say whether default setups are affected
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity7.5/10CVSS 7.5
- No patch0/5No signal
What would change the score
- Would score about 70 if added to CISA KEV
- Would score about 65 if CISA's SSVC rates exploitation active
- Would score about 30 if advisories confirm default setups are exposed
CVE-2026-17493 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.5 (high) and affects Watson Speech Services Cartridge; fixed in 5.4.0 Patch 8.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 25/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Unclear
- Fix
- Fixed in 5.4.0 Patch 8
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
IBM Watson Speech Services Cartridge is affected by a flaw that lets a remote attacker, without logging in, crash the service and cause a denial of service through an out-of-bounds read. The flaw can be reached over the network with no user action required.
Read the original description
IBM Watson Speech Services Cartridge 4.0.0 through 5.4.0 could allow a remote attacker to cause a denial of service due to an out-of-bounds read.
What to do
Upgrade to a fixed version: 5.4.0 Patch 8.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- IBM Watson Speech Services Cartridge
From 4.0.0 · through 5.4.0
Evidence 1
- Patch
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-17493
Is CVE-2026-17493 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
Under certain conditions, the Unpacker component can read memory outside its allowed bounds (an out-of-bounds read), which can make the process crash with a SEGV. This is a denial of service: the service stops, but the flaw is described as causing a crash rather than giving access to data.Source: ibm.com
Which versions are affected by CVE-2026-17493?
Watson Speech Services Cartridge: from 4.0.0 through 5.4.0.Source: cve.now feed data
Am I affected, and how do I check?
IBM Watson Speech Services Cartridge versions 4.0.0 through 5.4.0 are listed as affected. The bug needs the Unpacker to be used repeatedly after an error occurs, and untrusted input from external sources can trigger it. To check a installed version, look at the cartridge version shown in your IBM Watson Speech Services deployment.Source: ibm.com
How do I fix CVE-2026-17493?
Upgrade to 5.4.0 Patch 8, which IBM says fixes all versions listed from 4.0.0 through 5.4.0. No workaround is listed in the facts.Source: ibm.com