Frappe ERPNext before 15.121.4 and 16.36.0 Missing Authorization via get_linked_payments_for_doc
- Exploited
- No known exploitation
- Fix
- Fixed in 15.121.4, 16.36.0
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 15.121.4, 16.36.0.
- Last modified
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 8/100 · provisional
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
The Frappe ERPNext software is affected by a missing authorization flaw in its get_linked_payments_for_doc method. A remote attacker with a low-privilege logged-in account, including a portal user, can read payment allocation data belonging to other companies' invoices and vouchers.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
Read the original description
Frappe ERPNext before 15.121.4 and 16.x before 16.36.0 contains a missing authorization vulnerability in the whitelisted get_linked_payments_for_doc method. Any authenticated user, including portal users, can supply arbitrary company, doctype, and docname values to read Payment Ledger Entry allocation data for other companies' invoices and vouchers.
cve.now Index
- Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
- Exposure3/25Reachable over the network · Unknown: No advisory context yet
- Reach?/20Unknown. No tracked technology or package matched
- Severity5.3/10CVSS 5.3
- No patch0/5No signal
What would change the score
- Would score about 63 if added to CISA KEV
- Would score about 58 if CISA's SSVC rates exploitation active
- Would score about 27 if advisories confirm default setups are exposed
What to do
Upgrade to a fixed version: 15.121.4, 16.36.0.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- frappe erpnext
fixed in 15.121.4; From 16.0.0-beta.1 · fixed in 16.36.0
Evidence 6
- Advisory
- Patch
- Patch
- Repository
- Repository
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-124313
Is CVE-2026-124313 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
Which versions are affected by CVE-2026-124313?
erpnext: before 15.121.4; from 16.0.0-beta.1 before 16.36.0.Source: cve.now feed data
How do I fix CVE-2026-124313?
Upgrade to a fixed version: 15.121.4, 16.36.0.Source: cve.now feed data