Skip to main content
← Vulnerabilities

Hickory DNS through 0.26.0-alpha.1 DNSSEC Validation Bypass via Ancestor-Delegation NSEC3

Affects hickory-proto 0.25 through 0.26.0-alpha.1 and hickory-net 0.26.0-beta.1 before 0.26.2, when the validating recursor's NSEC3 handler is used. Fixed in 0.26.2.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

8.7HighCNA
Exploited
No known exploitation
Fix
Fixed in 0.26.2
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Uses the validating recursor's NSEC3 handler (hickory-proto 0.25 through 0.26.0-alpha.1, or hickory-net 0.26.0-beta.1 before 0.26.2). Affected release range: hickory-proto 0.25 through 0.26.0-alpha.1 and hickory-net 0.26.0-beta.1 before 0.26.2.

Published
Last modified
17/100 · provisional
Specific setups only
None on Exploit-DB, Metasploit or GitHub

Summary

Hickory DNS hickory-proto 0.25 through 0.26.0-alpha.1 and hickory-net 0.26.0-beta.1 before 0.26.2 contain a DNSSEC validation flaw in the validating recursor's NSEC3 handler, which matches the closest encloser by hash alone without checking the type bitmap and so accepts parent-side ancestor-delegation NSEC3 records as proof of nonexistence. An attacker who delivers one response built from genuinely signed parent NSEC3 records can cause NXDOMAIN or NODATA to be cached with AD=1, denying resolution of existing names at and below the zone cut.

cve.now Index

17Pcve.now Index 17 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure8/25Specific setups only, reachable over the network
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity8.7/10CVSS 8.7
  • No patch0/5No signal

What would change the score

  • Would score about 67 if added to CISA KEV
  • Would score about 62 if CISA's SSVC rates exploitation active
  • Would score about 24 if CISA's SSVC rates it automatable

What to do

  • Check whether your setup matches what the bug needs.

    Uses the validating recursor's NSEC3 handler (hickory-proto 0.25 through 0.26.0-alpha.1, or hickory-net 0.26.0-beta.1 before 0.26.2). Affected release range: hickory-proto 0.25 through 0.26.0-alpha.1 and hickory-net 0.26.0-beta.1 before 0.26.2.
  • Upgrade to a fixed version: 0.26.2.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • hickory-dns hickory-dns

    From 0.25 · through 0.26.0-alpha.1

  • hickory-dns hickory-dns

    From 0.26.0-beta.1 · fixed in 0.26.2

Evidence 2

  1. Advisory
  2. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-123595

Is CVE-2026-123595 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

The validating recursor's NSEC3 handler does not implement the check needed for ancestor-delegation NSEC3 records. As a result, the resolver can cache a forged NXDOMAIN or NODATA response marked AD=1, which denies resolution of names that legitimately exist at and below the zone cut.Source: github.com, vulncheck.com

Which versions are affected by CVE-2026-123595?

hickory-dns: from 0.25 through 0.26.0-alpha.1. hickory-dns: from 0.26.0-beta.1 before 0.26.2.Source: cve.now feed data

Am I affected, and how do I check?

The affected releases are hickory-proto 0.25 through 0.26.0-alpha.1 and hickory-net 0.26.0-beta.1 before 0.26.2. To check a project, look up the installed hickory-proto or hickory-net version in its dependency lockfile and confirm whether it uses the validating recursor.Source: github.com, vulncheck.com

How do I fix CVE-2026-123595?

Upgrade to hickory-net 0.26.2, which is the fixed release. Projects that use hickory-proto should move to the release that contains the fix as listed in the advisory.Source: github.com, vulncheck.com