Skip to main content
← Vulnerabilities

accel-ppp before 1.15.0 Heap-based Buffer Overflow via oversized log lines in log_tcp/log_syslog/log_pgsql

Affects accel-ppp before 1.15.0 when verbose logging is enabled with the tcp, syslog or pgsql log target. Fixed in 1.15.0.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

8.3HighCNA
Exploited
No known exploitation
Fix
Fixed in 1.15.0
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 1.15.0.

Published
Last modified
25/100 · provisional
Unclear
None on Exploit-DB, Metasploit or GitHub

Summary

Remote attackers who can reach accel-ppp's L2TP service over the network, without logging in, can overflow a heap buffer by sending oversized log-generating requests when verbose logging is enabled, which can corrupt memory and crash the daemon. The flaw is in the tcp, syslog, and pgsql log targets of accel-ppp.

Read the original description

accel-ppp before 1.15.0 contains a heap buffer overflow vulnerability in the tcp, syslog and pgsql log targets that allows unauthenticated remote peers to overflow fixed heap buffers by producing log lines exceeding LOG_MAX_SIZE. Attackers within client-ip-range can send an L2TP Start-Control-Connection-Request with many string AVPs when verbose logging is enabled to corrupt heap memory and crash the daemon.

cve.now Index

25Pcve.now Index 25 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure17/25No login or user action needed, reachable over the network without a login · Unknown: Advisories don't say whether default setups are affected
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity8.3/10CVSS 8.3
  • No patch0/5No signal

What would change the score

  • Would score about 70 if added to CISA KEV
  • Would score about 65 if CISA's SSVC rates exploitation active
  • Would score about 30 if advisories confirm default setups are exposed

What to do

  • Upgrade to a fixed version: 1.15.0.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • accel-ppp accel-ppp

    fixed in 1.15.0

Evidence 5

  1. Patch
  2. Patch
  3. Repository
  4. Repository
  5. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-123205

Is CVE-2026-123205 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

Oversized log lines sent to the tcp, syslog or pgsql log targets overflow a heap buffer. This can corrupt heap memory and crash the accel-ppp daemon.Source: vulncheck.com

Which versions are affected by CVE-2026-123205?

accel-ppp: before 1.15.0.Source: cve.now feed data

Am I affected, and how do I check?

Versions before 1.15.0 are affected, and only when verbose logging is enabled and the tcp, syslog or pgsql log target is used. Check the installed version and the logging configuration to see whether this setup applies.Source: vulncheck.com

How do I fix CVE-2026-123205?

Upgrade to accel-ppp 1.15.0 or later, which contains the fix.Source: vulncheck.com