libnxml before 0.18.6 Stack-based Buffer Overflow via long multi-byte XML name
Affects libnxml before 0.18.6 when parsing XML or RSS feeds with a long multi-byte name. Fixed in 0.18.6.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 0.18.6
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 0.18.6.
- Last modified
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 29/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Unclear
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: yes
- Technical impact: partial
Summary
libnxml before 0.18.6 has a stack-based buffer overflow that lets a remote attacker, without logging in, crash applications that parse XML or RSS feeds by supplying a feed with an overly long name ending in a multi-byte UTF-8 character. The flaw is in how the library handles element, attribute, DOCTYPE, and entity names, and its impact is a denial of service rather than code execution.
Read the original description
libnxml before 0.18.6 contains a stack-based buffer overflow vulnerability in src/nxml_parser.c that allows remote attackers to write past a 1024-byte stack buffer via long XML names. Attackers can supply XML or RSS feeds with a 1022-character element, attribute, DOCTYPE or entity name ending in a multi-byte UTF-8 character to crash parsing applications.
cve.now Index
- Exploitation0/40No signal
- Exposure20/25No login or user action needed, CISA rates it automatable · Unknown: Advisories don't say whether default setups are affected
- Reach?/20Unknown. No tracked technology or package matched
- Severity8.7/10CVSS 8.7
- No patch0/5No signal
What would change the score
- Would score about 74 if added to CISA KEV
- Would score about 69 if CISA's SSVC rates exploitation active
- Would score about 34 if advisories confirm default setups are exposed
What to do
Upgrade to a fixed version: 0.18.6.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: yes · Technical impact: partial
- Record last updated
Affected versions
- bakulf libnxml
fixed in 0.18.6
Evidence 4
- Patch
- Repository
- Repository
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-123202
Is CVE-2026-123202 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
A crafted feed with a 1022-character element, attribute, DOCTYPE or entity name ending in a multi-byte UTF-8 character overflows a buffer on the stack. The overflow can crash the application parsing the feed, causing a denial of service.Source: vulncheck.com
Which versions are affected by CVE-2026-123202?
libnxml: before 0.18.6.Source: cve.now feed data
Am I affected, and how do I check?
libnxml versions before 0.18.6 are affected, with no lower bound listed. Check the installed libnxml version in your package manager or build configuration to see whether it is below 0.18.6; the risk applies when the parser reads XML or RSS feeds with such long names.Source: vulncheck.com
How do I fix CVE-2026-123202?
Upgrade libnxml to 0.18.6 or later. No workaround is listed in the checked facts.Source: vulncheck.com