Skip to main content
← Vulnerabilities

An OS Command Injection vulnerability was discovered in the Google Cloud DNS validation module of the OPNsense os-acme-client plugin…

9.4CriticalCNA
Exploited
No known exploitation
Fix
Fixed in 4.18
Who is exposed
Specific setups only

Do first: Upgrade to a fixed version: 4.18.

Published
Last modified
0.63% · 50th percentile
17/100 · provisional
Specific setups only
None on Exploit-DB, Metasploit or GitHub
On X
View the cve.now post

Summary

The OPNsense os-acme-client plugin's Google Cloud DNS validation module contains an OS command injection flaw. A remote attacker with low-privilege login rights who can issue or renew certificates through the WebGUI or API can run arbitrary commands as root.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

Read the original description

An OS Command Injection vulnerability was discovered in the Google Cloud DNS validation module of the OPNsense os-acme-client plugin through 4.17. The DnsGcloud::prepare() method decodes the dns_gcloud_key model field and directly interpolates the string fields gcloud_account and gcloud_project into a shell command passed to proc_open() via LeUtils::run_shell_command() without any validation or escaping. A remote authenticated user with privileges to issue or renew certificates through the WebGUI/API can achieve arbitrary code execution as root.

cve.now Index

17Pcve.now Index 17 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure8/25Specific setups only, reachable over the network
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity9.4/10CVSS 9.4
  • No patch0/5No signal

What would change the score

  • Would score about 67 if added to CISA KEV
  • Would score about 62 if CISA's SSVC rates exploitation active
  • Would score about 24 if CISA's SSVC rates it automatable

What to do

  • Upgrade to a fixed version: 4.18.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. Posted on X by cve.now

Affected versions

  • OPNsense os-acme-client

    through 4.17.0

Evidence 1

  1. Repository

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-123025

Is CVE-2026-123025 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

Which versions are affected by CVE-2026-123025?

os-acme-client: through 4.17.0.Source: cve.now feed data

How do I fix CVE-2026-123025?

Upgrade os-acme-client to version 4.18 or later, which is the release that contains the fix. No workaround is listed in the checked facts.Source: github.com