Skip to main content
← Vulnerabilities

iTerm2 before 3.7.7beta2 has an argument injection vulnerability in the x-man-page: URL handler, allowing an attacker to execute arbitrary…

Affects iTerm2 before 3.7.7beta2 when it receives a crafted x-man-page: URL; browser-based delivery requires iTerm2 to be the selected handler for that scheme. Fixed in 3.7.7beta2 and 3.7.7.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

8.7HighCNA
Exploited
No known exploitation
Fix
Fixed in 3.7.7beta2
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. A vulnerable version of iTerm2 must be installed and receive the crafted x-man-page: URL For browser-based delivery, iTerm2 must be selected as the application that handles the x-man-page: URL scheme

Published
Last modified
0.47% · 41st percentile
21/100 · provisional
Specific setups only
None on Exploit-DB, Metasploit or GitHub

Summary

iTerm2, a macOS terminal application, is affected by an argument injection flaw in its x-man-page URL handler that lets an attacker run arbitrary commands with the privileges of the logged-in user. The attack is reached remotely without logging in, but it requires the user to open a crafted URL in iTerm2.

Read the original description

iTerm2 before 3.7.7beta2 has an argument injection vulnerability in the x-man-page: URL handler, allowing an attacker to execute arbitrary commands with the privileges of the logged-in user by inducing the user to open a crafted URL in iTerm2. Percent-encoded NUL characters survive input sanitization and are subsequently converted to whitespace during command-line parsing, allowing injection of additional arguments to /usr/bin/man. An attacker can inject the -P option to select an attacker-controlled pager command. NOTE: this issue exists because of an incomplete fix for CVE-2023-46321.

cve.now Index

21Pcve.now Index 21 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure12/25Specific setups only, reachable over the network without a login
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity8.7/10CVSS 8.7
  • No patch0/5No signal

What would change the score

  • Would score about 71 if added to CISA KEV
  • Would score about 66 if CISA's SSVC rates exploitation active

What to do

  • Check whether your setup matches what the bug needs.

    A vulnerable version of iTerm2 must be installed and receive the crafted x-man-page: URL For browser-based delivery, iTerm2 must be selected as the application that handles the x-man-page: URL scheme
  • Upgrade to a fixed version: 3.7.7beta2.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • iTerm2 iTerm2

    fixed in 3.7.7beta2

Evidence 3

  1. Patch
  2. Patch
  3. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-123014

Is CVE-2026-123014 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

The x-man-page: URL handler in iTerm2 has an argument injection flaw, meaning crafted text in the URL can be interpreted as extra command arguments. The CVE description is cut off, so the full impact is not stated in the facts provided.Source: cve.org

Which versions are affected by CVE-2026-123014?

iTerm2: before 3.7.7beta2.Source: cve.now feed data

Am I affected, and how do I check?

All iTerm2 versions before 3.7.7beta2 are in the affected range. Browser-based delivery additionally requires iTerm2 to be selected as the application that handles the x-man-page: URL scheme, so the installed version and that handler setting are the two things to check.Source: cve.org

How do I fix CVE-2026-123014?

Upgrade to iTerm2 3.7.7beta2 or later, with 3.7.7 being the stable release that includes the fix.Source: cve.org