Kyverno before 1.19.2 Denial of Service via In/NotIn Operator Panic
- Exploited
- No known exploitation
- Fix
- Fixed in 1.19.2
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 1.19.2.
- Last modified
- FIRST's estimate of the chance attackers exploit it in the next 30 days, updated daily.What do these mean? →
- 0.28% · 20th percentile
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 26/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Unclear
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Kyverno versions before 1.19.2 contain a denial-of-service flaw in the In and NotIn operators that can be triggered remotely, without logging in, by submitting resources whose evaluated values are arrays of integers, booleans, or mixed types. An attacker who does so can crash the policy engine, disrupting admission control and policy enforcement.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
Read the original description
Kyverno before 1.19.2 contains a denial-of-service vulnerability in the In and NotIn operators that allows attackers to crash the policy engine via an unchecked type assertion. Attackers can submit resources whose JMESPath-evaluated values yield arrays of integers, booleans, or mixed types, triggering a panic that disrupts admission control and policy enforcement.
cve.now Index
- Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
- Exposure17/25No login or user action needed, reachable over the network without a login · Unknown: Advisories don't say whether default setups are affected
- Reach?/20Unknown. No tracked technology or package matched
- Severity8.7/10CVSS 8.7
- No patch0/5No signal
What would change the score
- Would score about 71 if added to CISA KEV
- Would score about 66 if CISA's SSVC rates exploitation active
- Would score about 31 if advisories confirm default setups are exposed
What to do
Upgrade to a fixed version: 1.19.2.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- kyverno kyverno
fixed in 1.19.2
Evidence 2
- Advisory
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-122319
Is CVE-2026-122319 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
Kyverno can crash with a runtime panic when an In or NotIn operator evaluates a key that is a list containing non-string values such as integers, booleans, objects or mixed types. Such keys are commonly produced through variable substitution or JMESPath evaluation. A crash of the policy engine or admission controller is a denial of service.Source: github.com
Which versions are affected by CVE-2026-122319?
kyverno: before 1.19.2.Source: cve.now feed data
Am I affected, and how do I check?
Kyverno versions before 1.19.2 are affected, and the GitHub advisory lists 1.18.1 as an affected version. To check a installation, look at the Kyverno version it runs, and check whether policies use In or NotIn with keys produced by variable substitution or JMESPath.Source: github.com
How do I fix CVE-2026-122319?
Upgrade Kyverno to 1.19.2 or later, which is the listed patched version.Source: github.com