Kyverno before 1.19.2 Denial of Service via Shallow Variable Substitution Panic
Affects Kyverno before 1.19.2 when a policy uses shallow ({{- variable }}) substitution on a field whose value is not a string. Fixed in 1.19.2.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 1.19.2
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 1.19.2.
- Last modified
- FIRST's estimate of the chance attackers exploit it in the next 30 days, updated daily.What do these mean? →
- 0.30% · 23rd percentile
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 26/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Unclear
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Kyverno, a Kubernetes policy engine, can be crashed by a remote, unauthenticated attacker who submits resources with non-string fields referenced by shallow variable substitution in policies. The resulting panic can take down the webhook, causing denial of service and, under failurePolicy Ignore, letting resources bypass policy checks.
Read the original description
Kyverno before 1.19.2 contains an unchecked type assertion in its variable-substitution engine that allows users who can submit resources to crash the policy engine. Attackers can submit resources with non-string fields referenced by {{- variable }} shallow substitution in policies, causing a panic that yields webhook denial of service and policy bypass under failurePolicy Ignore.
cve.now Index
- Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
- Exposure17/25No login or user action needed, reachable over the network without a login · Unknown: Advisories don't say whether default setups are affected
- Reach?/20Unknown. No tracked technology or package matched
- Severity8.7/10CVSS 8.7
- No patch0/5No signal
What would change the score
- Would score about 71 if added to CISA KEV
- Would score about 66 if CISA's SSVC rates exploitation active
- Would score about 31 if advisories confirm default setups are exposed
What to do
Upgrade to a fixed version: 1.19.2.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- kyverno kyverno
fixed in 1.19.2
Evidence 2
- Advisory
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-122314
Is CVE-2026-122314 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
An unchecked type assertion in Kyverno's variable substitution causes the policy engine to panic and crash when shallow substitution is applied to a non-string field. This can cause webhook denial of service and, for failurePolicy Ignore policies, a policy bypass.Source: vulncheck.com, github.com
Which versions are affected by CVE-2026-122314?
kyverno: before 1.19.2.Source: cve.now feed data
Am I affected, and how do I check?
Kyverno versions before 1.19.2 are affected, but only when a policy uses shallow ({{- variable }}) substitution on a field whose value is not a string. To check, look at the Kyverno version in your deployment and search your policies for shallow {{- variable }} substitution.Source: vulncheck.com, github.com
How do I fix CVE-2026-122314?
Upgrade Kyverno to 1.19.2 or later, which contains the fix.Source: vulncheck.com, github.com