Skip to main content
← Vulnerabilities

Kyverno 1.17.0 before 1.19.2 Cross-Namespace Privilege Escalation via NamespacedMutatingPolicy

Affects Kyverno 1.17.0 before 1.19.2 where a namespace-scoped tenant can create a NamespacedMutatingPolicy with mutateExisting, which runs under the cluster-wide background controller. Fixed in 1.19.2.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

9.4CriticalCNA
Exploited
No known exploitation
Fix
Fixed in 1.19.2
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Kyverno version affected: <= 1.19.0 (per GHSA advisory); affected range 1.17.0 before 1.19.2 Attacker must be able to create a NamespacedMutatingPolicy with mutateExisting enabled and a targetMatchConstraints.expression Background controller ServiceAccount holds cluster-wide write permissions on the affected resources (no per-user impersonation)

Published
Last modified
0.31% · 24th percentile
17/100 · provisional
Specific setups only
None on Exploit-DB, Metasploit or GitHub
On X
View the cve.now post

Summary

Kyverno, a Kubernetes policy engine, in releases before the patched version contains a privilege escalation flaw in NamespacedMutatingPolicy that lets a namespace-scoped tenant modify resources in other namespaces. A remote attacker with low-privilege credentials can craft a target expression that points at another tenant's RoleBinding, causing the cluster-wide background controller to add attacker subjects or alter Roles, NetworkPolicies, and ConfigMaps.

Read the original description

Kyverno from 1.17.0 before 1.19.2 contains a privilege escalation vulnerability that allows namespace-scoped tenants to modify resources in other namespaces through NamespacedMutatingPolicy targetMatchConstraints.expression CEL output lacking namespace checks. Attackers can emit a literal target such as another tenant's RoleBinding, which the cluster-wide background controller then mutates to add attacker subjects or alter Roles, NetworkPolicies, and ConfigMaps.

cve.now Index

17Pcve.now Index 17 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure8/25Specific setups only, reachable over the network
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity9.4/10CVSS 9.4
  • No patch0/5No signal

What would change the score

  • Would score about 67 if added to CISA KEV
  • Would score about 62 if CISA's SSVC rates exploitation active
  • Would score about 24 if CISA's SSVC rates it automatable

What to do

  • Check whether your setup matches what the bug needs.

    Kyverno version affected: <= 1.19.0 (per GHSA advisory); affected range 1.17.0 before 1.19.2 Attacker must be able to create a NamespacedMutatingPolicy with mutateExisting enabled and a targetMatchConstraints.expression Background controller ServiceAccount holds cluster-wide write permissions on the affected resources (no per-user impersonation)
  • Upgrade to a fixed version: 1.19.2.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. Posted on X by cve.now

Affected versions

  • kyverno kyverno

    From 1.17.0 · fixed in 1.19.2

Evidence 2

  1. Advisory
  2. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-122313

Is CVE-2026-122313 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

A namespace-scoped tenant can create a NamespacedMutatingPolicy that makes the cluster-wide background controller modify resources in other tenants' namespaces. The advisory gives examples such as adding subjects to a RoleBinding or changing Roles, NetworkPolicies, and ConfigMaps, which leads to cross-namespace privilege escalation.Source: github.com

Which versions are affected by CVE-2026-122313?

kyverno: from 1.17.0 before 1.19.2.Source: cve.now feed data

Am I affected, and how do I check?

The GHSA advisory lists Kyverno versions up to and including 1.19.0 as affected, within the range 1.17.0 before 1.19.2. The exposed setup requires NamespacedMutatingPolicy with mutateExisting enabled and a targetMatchConstraints.expression, and a background controller ServiceAccount with cluster-wide write permissions. Check the installed Kyverno version and whether NamespacedMutatingPolicy resources are in use.Source: github.com

How do I fix CVE-2026-122313?

Upgrade Kyverno to 1.19.2, which is the listed patched version. No workaround is listed in the facts.Source: github.com