Skip to main content
← Vulnerabilities

Kyverno 1.16.0 before 1.19.2 Path Traversal in Namespaced CEL Policies via resource argument

Affects Kyverno 1.16.0 before 1.19.2, where namespaced CEL policies can escape their namespace. Fixed in 1.19.2.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

9.4CriticalCNA
Exploited
No known exploitation
Fix
Fixed in 1.19.2
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Kyverno version 1.16.0 through before 1.19.2 (affected versions <= 1.19.0 per GitHub advisory). Attacker must be able to create a NamespacedValidatingPolicy in their own namespace.

Published
Last modified
0.45% · 39th percentile
17/100 · provisional
Specific setups only
None on Exploit-DB, Metasploit or GitHub
On X
View the cve.now post

Summary

Kyverno, a Kubernetes policy engine, is affected by a path traversal flaw in namespaced CEL policies that lets a tenant with permission to create a NamespacedValidatingPolicy escape its namespace and read and write arbitrary cluster objects using the admission controller's ServiceAccount, which can lead to full cluster takeover. The attacker reaches it over the network with low-privilege login and no user interaction.

Read the original description

Kyverno from 1.16.0 before 1.19.2 fails to validate path segments in the resource argument of resource.get() and resource.post(), allowing namespaced CEL policies to escape their namespace. Tenants who can create a NamespacedValidatingPolicy can insert .. segments to read and write arbitrary cluster objects using the admission controller's ServiceAccount, leading to cluster takeover.

cve.now Index

17Pcve.now Index 17 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure8/25Specific setups only, reachable over the network
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity9.4/10CVSS 9.4
  • No patch0/5No signal

What would change the score

  • Would score about 67 if added to CISA KEV
  • Would score about 62 if CISA's SSVC rates exploitation active
  • Would score about 24 if CISA's SSVC rates it automatable

What to do

  • Check whether your setup matches what the bug needs.

    Kyverno version 1.16.0 through before 1.19.2 (affected versions <= 1.19.0 per GitHub advisory). Attacker must be able to create a NamespacedValidatingPolicy in their own namespace.
  • Upgrade to a fixed version: 1.19.2.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. Posted on X by cve.now

Affected versions

  • kyverno kyverno

    From 1.16.0 · fixed in 1.19.2

Evidence 2

  1. Advisory
  2. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-122311

Is CVE-2026-122311 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

Kyverno fails to validate path segments in the resource argument of namespaced CEL policies, which lets a policy escape its own namespace. The advisory says this allows reading and writing arbitrary cluster objects using the Kyverno admission controller's ServiceAccount.Source: vulncheck.com, github.com

Which versions are affected by CVE-2026-122311?

kyverno: from 1.16.0 before 1.19.2.Source: cve.now feed data

Am I affected, and how do I check?

Kyverno versions from 1.16.0 before 1.19.2 are affected. To check a cluster, look at the installed Kyverno version, for example with kubectl get deployment -n kyverno or helm list -n kyverno. The bug concerns namespaced CEL policies (NamespacedValidatingPolicy), and the advisory's prerequisite is the ability to create those policies in a namespace.Source: vulncheck.com, github.com

How do I fix CVE-2026-122311?

Upgrade Kyverno to version 1.19.2 or later, which contains the fix.Source: vulncheck.com, github.com