Kyverno before 1.19.2 Denial of Service via Unbounded CEL Policy Evaluation Cost
Affects Kyverno 1.19.1 and earlier when CEL policy expressions run without runtime cost limits, including namespaced policies. Fixed in 1.19.2.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 1.19.2
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. Kyverno version 1.19.1 or earlier (fixed in 1.19.2) Kyverno CEL policy expressions evaluated without runtime cost limits, including namespaced policies
- Last modified
- FIRST's estimate of the chance attackers exploit it in the next 30 days, updated daily.What do these mean? →
- 0.20% · 9th percentile
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 16/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Kyverno versions before 1.19.2 can be made to crash through a denial-of-service flaw in how they evaluate CEL policy expressions. An attacker who has privileges to create namespace-scoped policies can reach it over the network, but only after logging in with high privileges and needing a user to take an action, and the attack can exhaust CPU and memory so that Kyverno pods are killed and cluster-wide admission is blocked.
Read the original description
Kyverno before 1.19.2 contains a denial of service vulnerability that allows namespace-scoped policy authors to exhaust CPU and memory by submitting CEL expressions evaluated without runtime cost limits. Attackers can create a NamespacedValidatingPolicy or NamespacedDeletingPolicy with nested map comprehensions over large ConfigMap fields to OOM-kill Kyverno pods and block cluster-wide admission.
cve.now Index
- Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
- Exposure8/25Specific setups only, reachable over the network
- Reach?/20Unknown. No tracked technology or package matched
- Severity8.2/10CVSS 8.2
- No patch0/5No signal
What would change the score
- Would score about 66 if added to CISA KEV
- Would score about 61 if CISA's SSVC rates exploitation active
- Would score about 23 if CISA's SSVC rates it automatable
What to do
Check whether your setup matches what the bug needs.
Kyverno version 1.19.1 or earlier (fixed in 1.19.2) Kyverno CEL policy expressions evaluated without runtime cost limits, including namespaced policiesUpgrade to a fixed version: 1.19.2.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- kyverno kyverno
fixed in 1.19.2
Evidence 2
- Advisory
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-122309
Is CVE-2026-122309 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
A namespace tenant can submit a CEL policy expression that Kyverno evaluates without any runtime cost limit. This can exhaust CPU and memory on the shared Kyverno control plane and get its pods OOM-killed, causing denial of service.Source: vulncheck.com, github.com
Which versions are affected by CVE-2026-122309?
kyverno: before 1.19.2.Source: cve.now feed data
Am I affected, and how do I check?
Kyverno versions before 1.19.2 are affected, including namespaced validating policies. To check a deployment, look at the installed Kyverno version and whether it is 1.19.1 or earlier.Source: vulncheck.com, github.com
How do I fix CVE-2026-122309?
Upgrade Kyverno to 1.19.2 or later, which fixes this issue.Source: vulncheck.com, github.com