Skip to main content
← Vulnerabilities

Kyverno 1.17.0 before 1.19.2 Privilege Escalation via CleanupPolicy Context Loader

Kyverno 1.17.0 through 1.19.1 is affected when namespaced CleanupPolicy resources use apiCall or globalReference context entries, and the cleanup controller is enabled by default. Fixed in 1.19.2.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

9.4CriticalCNA
Exploited
No known exploitation
Fix
Fixed in 1.19.2
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Kyverno version 1.17.0 through 1.19.1 (before 1.19.2) Attacker can create a namespaced CleanupPolicy with apiCall or globalReference context entries The cleanup controller is enabled by default

Published
Last modified
0.39% · 33rd percentile
17/100 · provisional
Specific setups only
None on Exploit-DB, Metasploit or GitHub
On X
View the cve.now post

Summary

Kyverno, a Kubernetes policy engine, from 1.17.0 before 1.19.2 has a privilege escalation flaw in its CleanupPolicy context loader. Remotely, with low-privilege login, an attacker who is a namespace admin can create a namespaced CleanupPolicy to read cross-namespace Secrets and modify validatingwebhookconfigurations using the cleanup controller's ServiceAccount, escaping namespace confinement.

Read the original description

Kyverno from 1.17.0 before 1.19.2 contains an authorization bypass vulnerability that allows namespace admins to escape namespace confinement because the cleanup controller builds its context loader with a nil policy. Attackers can create a namespaced CleanupPolicy with apiCall or globalReference context entries to read cross-namespace Secrets and modify validatingwebhookconfigurations using the cleanup controller's ServiceAccount.

cve.now Index

17Pcve.now Index 17 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure8/25Specific setups only, reachable over the network
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity9.4/10CVSS 9.4
  • No patch0/5No signal

What would change the score

  • Would score about 67 if added to CISA KEV
  • Would score about 62 if CISA's SSVC rates exploitation active
  • Would score about 24 if CISA's SSVC rates it automatable

What to do

  • Check whether your setup matches what the bug needs.

    Kyverno version 1.17.0 through 1.19.1 (before 1.19.2) Attacker can create a namespaced CleanupPolicy with apiCall or globalReference context entries The cleanup controller is enabled by default
  • Upgrade to a fixed version: 1.19.2.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. Posted on X by cve.now

Affected versions

  • kyverno kyverno

    From 1.17.0 · fixed in 1.19.2

Evidence 3

  1. Advisory
  2. Advisory
  3. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-122304

Is CVE-2026-122304 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

A namespace admin can create a namespaced CleanupPolicy with apiCall or globalReference context entries and use the cleanup controller's ServiceAccount to read Secrets in other namespaces and modify validatingwebhookconfigurations, escaping namespace confinement.Source: github.com, vulncheck.com

Which versions are affected by CVE-2026-122304?

kyverno: from 1.17.0 before 1.19.2.Source: cve.now feed data

Am I affected, and how do I check?

Kyverno versions 1.17.0 through 1.19.1 (before 1.19.2) are affected. Check the installed Kyverno version, and check whether any namespaced CleanupPolicy uses apiCall or globalReference context entries, since the cleanup controller is enabled by default.Source: github.com, vulncheck.com

How do I fix CVE-2026-122304?

Upgrade Kyverno to 1.19.2, which contains the fix.Source: github.com, vulncheck.com