Skip to main content
← Vulnerabilities

jsondiffpatch before 0.7.7 XSS via Array-Move Destination in HTML Formatters

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

2.3LowCNA
Exploited
No known exploitation
Fix
Fixed in 0.7.7
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 0.7.7.

9Pcve.now Index 9 of 100 · methodology v3 · provisional
  • Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
  • Exposure7/25Reachable over the network without a login · Data gap: No advisory context yet
  • Reach?/20Reach: unknown (data gap). No tracked technology or package matched
  • Severity2.3/10CVSS 2.3
  • No patch0/5No signal

What would change the score

  • Would score about 64 if added to CISA KEV
  • Would score about 59 if CISA's SSVC rates exploitation active
  • Would score about 24 if advisories confirm default setups are exposed

CVE-2026-122234 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 2.3 (low) and affects jsondiffpatch; fixed in 0.7.7.

Published
Last modified
Published
Not listed in CISA KEV
9/100 · provisional
Fix
Fixed in 0.7.7
None on Exploit-DB, Metasploit or GitHub

Summary

jsondiffpatch versions before 0.7.7 contain a cross-site scripting flaw in its HTML and annotated formatters, which let an attacker inject script through an unescaped array-move destination index in a delta. An attacker can reach it remotely, without logging in, but a user must take an action, such as viewing the rendered output, before the injected script runs in the application's origin.

Read the original description

jsondiffpatch before 0.7.7 contains a cross-site scripting vulnerability that allows attackers to inject markup by supplying an unescaped array-move destination index in a delta. Attackers who control a delta passed to formatters.html.format() or formatters.annotated.format() can embed script that executes in the application's origin when output is rendered.

What to do

  • Upgrade to a fixed version: 0.7.7.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • benjamine jsondiffpatch

    fixed in 0.7.7

Evidence 3

  1. Advisory
  2. Patch
  3. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-122234

Is CVE-2026-122234 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

Which versions are affected by CVE-2026-122234?

jsondiffpatch: before 0.7.7.Source: cve.now feed data

How do I fix CVE-2026-122234?

Upgrade to a fixed version: 0.7.7.Source: cve.now feed data