Powerlevel10k before 1.20.19 Insecure Temporary Directory via gitstatus Installer
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 1.20.19
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 1.20.19.
- Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
- Exposure?/25Exposure: unknown (data gap). No advisory context yet
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity5.4/10CVSS 5.4
- No patch0/5No signal
What would change the score
- Would score about 60 if added to CISA KEV
- Would score about 55 if CISA's SSVC rates exploitation active
- Would score about 27 if advisories confirm default setups are exposed
CVE-2026-122137 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 5.4 (medium) and affects powerlevel10k and gitstatus; fixed in 1.20.19.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 5/100 · provisional
- Fix
- Fixed in 1.20.19
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Powerlevel10k, a Zsh theme, is affected by an insecure temporary directory flaw in its bundled gitstatus installer. A local attacker with low-privilege access and some user interaction can pre-create a predictable directory to swap in a malicious gitstatusd binary, which then runs with the victim's privileges, potentially compromising confidentiality, integrity, and availability on that system.
Read the original description
Powerlevel10k before 1.20.19 contains an insecure temporary directory vulnerability in the bundled gitstatus/install script that reuses attacker-creatable directories when mktemp fails. Local attackers can pre-create the predictable gitstatus-install.tmp directory to replace the extracted gitstatusd binary, which then executes with the victim's privileges.
What to do
Upgrade to a fixed version: 1.20.19.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- romkatv powerlevel10k
fixed in 1.20.19
- romkatv gitstatus
through 1.5.5
Evidence 6
- Patch
- Patch
- Report
- Repository
- Repository
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-122137
Is CVE-2026-122137 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
Which versions are affected by CVE-2026-122137?
powerlevel10k: before 1.20.19. gitstatus: through 1.5.5.Source: cve.now feed data
How do I fix CVE-2026-122137?
Upgrade to a fixed version: 1.20.19.Source: cve.now feed data