Mistral Vibe before 3.0.3 RCE via Repository-Configured gpg.program
Mistral Vibe before 3.0.3 is affected when a repository sets gpg.program and log.showSignature and has a signed commit. The fix is in 3.0.3.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 3.0.3
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. Mistral Vibe version before 3.0.3 Repository sets gpg.program and log.showSignature, and the project has a signed commit
- Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
- Exposure12/25Specific setups only, reachable over the network without a login
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity8.6/10CVSS 8.6
- No patch0/5No signal
What would change the score
- Would score about 71 if added to CISA KEV
- Would score about 66 if CISA's SSVC rates exploitation active
CVE-2026-122135 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.6 (high) and affects mistral-vibe; fixed in 3.0.3.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 21/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 3.0.3
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Mistral Vibe versions before 3.0.3 contain a flaw that lets an attacker run arbitrary commands on the affected machine. The attacker can reach it remotely, without logging in, through a crafted repository setting that makes git execute the attacker's program when a session starts, which requires the user to take an action such as opening that project.
Read the original description
Mistral Vibe before 3.0.3 contains a remote code execution vulnerability that allows attackers to run commands by abusing repository-configured gpg.program during project context collection. A crafted repository setting gpg.program and log.showSignature with a signed commit makes git log execute the attacker's program at session start, before any trust prompt.
What to do
Check whether your setup matches what the bug needs.
Mistral Vibe version before 3.0.3 Repository sets gpg.program and log.showSignature, and the project has a signed commitUpgrade to a fixed version: 3.0.3.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- mistralai mistral-vibe
fixed in 3.0.3
Evidence 6
- Patch
- Repository
- Repository
- Repository
- Repository
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-122135
Is CVE-2026-122135 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
A crafted repository setting can make git log run an attacker-chosen program at session start, before any trust prompt appears. This lets an attacker run arbitrary commands on the machine.Source: vulncheck.com
Which versions are affected by CVE-2026-122135?
mistral-vibe: before 3.0.3.Source: cve.now feed data
Am I affected, and how do I check?
Mistral Vibe versions before 3.0.3 are in the affected range. The vulnerable setup needs a repository that sets gpg.program and log.showSignature, with a signed commit in the project. Check the installed Mistral Vibe version against 3.0.3 to see whether it falls in the affected range.Source: vulncheck.com
How do I fix CVE-2026-122135?
Upgrade Mistral Vibe to 3.0.3 or later. The advisory lists no workaround.Source: vulncheck.com