CESNET ipfixcol2 2.3.0 before 2.9.0 Buffer Overflow via Forwarder Output Plugin
Only ipfixcol2 2.3.0 up to but not including 2.9.0 is affected, and only when the Forwarder output plugin forwards data over TCP. Fixed in 2.9.0.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 2.9.0
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 2.9.0.
- Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
- Exposure17/25No login or user action needed, reachable over the network without a login · Data gap: Advisories don't say whether default setups are affected
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity8.3/10CVSS 8.3
- No patch0/5No signal
What would change the score
- Would score about 70 if added to CISA KEV
- Would score about 65 if CISA's SSVC rates exploitation active
- Would score about 30 if advisories confirm default setups are exposed
CVE-2026-122130 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.3 (high) and affects ipfixcol2; fixed in 2.9.0.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 25/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Unclear
- Fix
- Fixed in 2.9.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
CESNET ipfixcol2 versions before 2.9.0 are affected through the Forwarder output plugin, which is used when the collector forwards data over TCP. Remotely, without logging in, an attacker who can act as an IPFIX exporter can send crafted data sets and templates that overflow a heap buffer, which can crash the collector and allow limited writes to attacker-influenced memory addresses.
Read the original description
CESNET ipfixcol2 2.3.0 before 2.9.0 contains an integer overflow vulnerability in the Forwarder output plugin that allows unauthenticated IPFIX exporters to overflow a heap buffer by wrapping uint16_t message length counters. Attackers can send near-65535-byte data sets and large templates to a collector forwarding over TCP to crash it and perform 2-byte writes to attacker-influenced addresses.
What to do
Upgrade to a fixed version: 2.9.0.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- CESNET ipfixcol2
From 2.3.0 · fixed in 2.9.0
Evidence 5
- Patch
- Repository
- Repository
- Repository
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-122130
Is CVE-2026-122130 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
The Forwarder output plugin contains an integer overflow. The advisory says this can crash the collector and lead to 2-byte writes to attacker-influenced addresses, overflowing a heap buffer.Source: vulncheck.com
Which versions are affected by CVE-2026-122130?
ipfixcol2: from 2.3.0 before 2.9.0.Source: cve.now feed data
Am I affected, and how do I check?
ipfixcol2 versions 2.3.0 up to but not including 2.9.0 are affected, and the issue concerns the Forwarder output plugin when the collector forwards data over TCP. To check, compare the installed ipfixcol2 version with that range and check whether the Forwarder output plugin is configured to use TCP.Source: vulncheck.com
How do I fix CVE-2026-122130?
Upgrade ipfixcol2 to 2.9.0 or later. The facts list no workaround, so the fixed version is the stated remedy.Source: vulncheck.com