CESNET ipfixcol2 2.7.1 before 2.9.0 Heap Buffer Overflow via TCP LZ4 Decoder
Affects ipfixcol2 2.7.1 up to but not including 2.9.0 when the TCP input plugin with the LZ4 decoder is used. Fixed in 2.9.0.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 2.9.0
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 2.9.0.
- Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
- Exposure17/25No login or user action needed, reachable over the network without a login · Data gap: Advisories don't say whether default setups are affected
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity8.7/10CVSS 8.7
- No patch0/5No signal
What would change the score
- Would score about 71 if added to CISA KEV
- Would score about 66 if CISA's SSVC rates exploitation active
- Would score about 31 if advisories confirm default setups are exposed
CVE-2026-122127 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.7 (high) and affects ipfixcol2; fixed in 2.9.0.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 26/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Unclear
- Fix
- Fixed in 2.9.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
CESNET ipfixcol2's TCP LZ4 decoder contains a heap-based buffer overflow that lets an attacker write past heap buffers and crash the collector. An attacker can reach it remotely, without logging in, by sending crafted LZ4 data that declares a small buffer size and a large decompressed size, allowing up to 65535 attacker-controlled bytes to be written.
Read the original description
CESNET ipfixcol2 2.7.1 before 2.9.0 contains a heap-based buffer overflow in Lz4Decoder.cpp that allows unauthenticated network peers to write past heap buffers. Attackers can declare a small ring buffer_size followed by a large decompressed_size to write up to 65535 controlled bytes and crash the collector.
What to do
Upgrade to a fixed version: 2.9.0.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- CESNET ipfixcol2
From 2.7.1 · fixed in 2.9.0
Evidence 5
- Patch
- Repository
- Repository
- Repository
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-122127
Is CVE-2026-122127 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
A heap buffer overflow in the TCP LZ4 decoder lets crafted input write up to 65535 controlled bytes past heap buffers, which crashes the collector.Source: vulncheck.com
Which versions are affected by CVE-2026-122127?
ipfixcol2: from 2.7.1 before 2.9.0.Source: cve.now feed data
Am I affected, and how do I check?
ipfixcol2 versions 2.7.1 up to but not including 2.9.0 are affected, and only when the TCP input plugin with the LZ4 decoder is used. To check, compare the installed ipfixcol2 version with that range and review whether the TCP input plugin with the LZ4 decoder is configured.Source: vulncheck.com
How do I fix CVE-2026-122127?
Upgrade to ipfixcol2 2.9.0, which is the fixed version listed in the v2.9.0 release notes.Source: vulncheck.com