In Yealink Plug-in Softwares before 2.35.219.0, there is an unauthorized file write vulnerability under specific scenarios, which may be…
Affects Yealink Plug-in Softwares before 2.35.219.0 on devices where it is installed and not updated. Fixed in 2.35.219.0.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 2.35.219.0
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 2.35.219.0.
- Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
- Exposure17/25No login or user action needed, reachable over the network without a login · Data gap: Advisories don't say whether default setups are affected
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity9/10CVSS 9.0
- No patch0/5No signal
What would change the score
- Would score about 71 if added to CISA KEV
- Would score about 66 if CISA's SSVC rates exploitation active
- Would score about 31 if advisories confirm default setups are exposed
CVE-2026-122120 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 9.0 (critical) and affects Plug-in Softwares; fixed in 2.35.219.0.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 26/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Unclear
- Fix
- Fixed in 2.35.219.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Yealink Plug-in Software versions before the fixed release are affected by an unauthorized file write flaw that appears in specific scenarios. Attackers can reach it remotely over the network without logging in, and it may allow them to run code on the system.
Read the original description
In Yealink Plug-in Softwares before 2.35.219.0, there is an unauthorized file write vulnerability under specific scenarios, which may be exploited by attackers to achieve remote code execution.
What to do
Upgrade to a fixed version: 2.35.219.0.
Timeline
- CVE published
- First seen by cve.now
- Posted on X by cve.now
Affected versions
- Yealink Plug-in Softwares
fixed in 2.35.219.0
Evidence 2
- Link
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-122120
Is CVE-2026-122120 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
The plug-in contains an unauthorized file write flaw under specific scenarios. The advisory says it can allow remote code execution.Source: yealink.com
Which versions are affected by CVE-2026-122120?
Plug-in Softwares: before 2.35.219.0.Source: cve.now feed data
Am I affected, and how do I check?
Yealink Plug-in Softwares versions before 2.35.219.0 are affected, under the specific scenarios the advisory describes. Compare the installed plug-in version with 2.35.219.0.Source: yealink.com
How do I fix CVE-2026-122120?
Update Yealink Plug-in Softwares to version 2.35.219.0 or a later version.Source: yealink.com