Skip to main content
← Vulnerabilities

Certain Yealink terminal devices before 2026-04-21 contain an improper access control vulnerability in the Wi-Fi 802.1X PEAP network…

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

4.3MediumCNA
Exploited
No known exploitation
Fix
Fixed in 124.87.0.22, 108.87.0.23, 96.87.0.24, 185.87.0.39, 180.87.0.15, and 7 more
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 124.87.0.22, 108.87.0.23, 96.87.0.24, 185.87.0.39, 180.87.0.15, or one of 7 more.

7Pcve.now Index 7 of 100 · methodology v3 · provisional
  • Exploitation0/40No signal
  • Exposure3/25Reachable over the network · Data gap: No advisory context yet
  • Reach?/20Reach: unknown (data gap). No tracked technology or package matched
  • Severity4.3/10CVSS 4.3
  • No patch0/5No signal

What would change the score

  • Would score about 62 if added to CISA KEV
  • Would score about 57 if CISA's SSVC rates exploitation active
  • Would score about 26 if advisories confirm default setups are exposed

CVE-2026-122116 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 4.3 (medium) and affects T3XW Series Phones, T4X Series Phones, T5X Series Phones and 10 more; fixed in 124.87.0.22, 108.87.0.23, 96.87.0.24 and 9 more.

Published
Last modified
Published
Not listed in CISA KEV
7/100 · provisional
Fix
Fixed in 124.87.0.22, 108.87.0.23, 96.87.0.24, 185.87.0.39, 180.87.0.15, and 7 more
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Certain Yealink terminal devices contain an improper access control flaw in their Wi-Fi 802.1X PEAP network configuration function, which exposes deployed 802.1X network access authentication credentials to unauthorized users. An attacker can reach it remotely over the network with a low-privilege login and no user action.

Read the original description

Certain Yealink terminal devices before 2026-04-21 contain an improper access control vulnerability in the Wi-Fi 802.1X PEAP network configuration function. This flaw exposes deployed 802.1X network access authentication credentials to unauthorized users. The latest Yealink firmware has addressed this vulnerability by restricting 802.1X configuration modification privileges to administrator accounts only by default.

What to do

  • Upgrade to a fixed version: 124.87.0.22, 108.87.0.23, 96.87.0.24, 185.87.0.39, 180.87.0.15, or one of 7 more.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  4. Record last updated

Affected versions

  • Yealink T3XW Series Phones

    From 124.85.0.1 · fixed in 124.87.0.22

  • Yealink T4X Series Phones

    From 108.85.0.1 · fixed in 108.87.0.23

  • Yealink T5X Series Phones

    From 96.85.0.1 · fixed in 96.87.0.24

  • Yealink T7X Series Phones

    From 185.87.0.5 · fixed in 185.87.0.39

  • Yealink SIP-T85W、SIP-T87W

    From 185.87.0.5 · fixed in 185.87.0.39

  • Yealink AX83H、AX86R

    From 180.86.0.1 · fixed in 180.87.0.15

  • Yealink CP925

    From 148.85.0.1 · fixed in 148.87.0.41

  • Yealink CP935W

    From 149.85.0.1 · fixed in 149.87.0.41

Show all 13 packagesShow fewer packages
  • Yealink MP E2 Teams Series

    From 176.15.0.1 · fixed in 176.15.0.191

  • Yealink VP59 Teams

    From 91.15.0.1 · fixed in 91.15.1.37

  • Yealink SIP-T58W

    From 150.86.0.5 · fixed in 150.87.0.22

  • Yealink VP59

    From 91.86.0.5 · fixed in 91.87.0.27

  • Yealink CP965

    From 143.86.0.5 · fixed in 143.87.0.27

Evidence 1

  1. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-122116

Is CVE-2026-122116 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

Which versions are affected by CVE-2026-122116?

T3XW Series Phones: from 124.85.0.1 before 124.87.0.22. T4X Series Phones: from 108.85.0.1 before 108.87.0.23. T5X Series Phones: from 96.85.0.1 before 96.87.0.24. T7X Series Phones: from 185.87.0.5 before 185.87.0.39. SIP-T85W、SIP-T87W: from 185.87.0.5 before 185.87.0.39. 8 more packages are listed on the page.Source: cve.now feed data

How do I fix CVE-2026-122116?

Upgrade to a fixed version: 124.87.0.22, 108.87.0.23, 96.87.0.24, 185.87.0.39, 180.87.0.15, or one of 7 more.Source: cve.now feed data