Coder before 2.29.22, 2.34.13, 2.35.10, 2.36.8, 2.37.5, and 2.38.1 AI Gateway Path Traversal
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 2.37.5, 2.36.8, 2.35.10, 2.34.13, 2.29.22, and 1 more
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 2.37.5, 2.36.8, 2.35.10, 2.34.13, 2.29.22, or one of 1 more.
- Exploitation0/40No signal
- Exposure3/25Reachable over the network · Data gap: No advisory context yet
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity2.3/10CVSS 2.3
- No patch0/5No signal
What would change the score
- Would score about 60 if added to CISA KEV
- Would score about 55 if CISA's SSVC rates exploitation active
- Would score about 24 if advisories confirm default setups are exposed
CVE-2026-121967 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 2.3 (low) and affects coder; fixed in 2.37.5, 2.36.8, 2.35.10 and 3 more.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 5/100 · provisional
- Fix
- Fixed in 2.37.5, 2.36.8, 2.35.10, 2.34.13, 2.29.22, and 1 more
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: partial
Summary
Coder, a software development platform, has a path traversal flaw in its AI Gateway passthrough router in certain versions before the fixed releases. A logged-in user can reach the network remotely and send crafted paths that get forwarded to unintended provider endpoints using the deployment's centrally managed provider key, which can expose or affect data at the provider side.
Read the original description
Coder 2.28.0 before 2.29.22, 2.30.0 before 2.34.13, 2.35.0 before 2.35.10, 2.36.0 before 2.36.8, 2.37.0 before 2.37.5, and 2.38.0 before 2.38.1 contains a path traversal vulnerability in the AI Gateway passthrough router, which forwards percent-encoded dot segments upstream without rejecting them. Authenticated users can send paths such as %2e%2e or ..%2F under allowlisted prefixes to reach unintended provider endpoints using the deployment's centrally managed provider key.
What to do
Upgrade to a fixed version: 2.37.5, 2.36.8, 2.35.10, 2.34.13, 2.29.22, or one of 1 more.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: partial
- Record last updated
Affected versions
- coder coder
From 2.37.0 · fixed in 2.37.5
- coder coder
From 2.36.0 · fixed in 2.36.8
- coder coder
From 2.35.0 · fixed in 2.35.10
- coder coder
From 2.30.0 · fixed in 2.34.13
- coder coder
From 2.28.0 · fixed in 2.29.22
- coder coder
From 2.38.0 · fixed in 2.38.1
Evidence 3
- Advisory
- Patch
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-121967
Is CVE-2026-121967 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
Which versions are affected by CVE-2026-121967?
coder: from 2.37.0 before 2.37.5. coder: from 2.36.0 before 2.36.8. coder: from 2.35.0 before 2.35.10. coder: from 2.30.0 before 2.34.13. coder: from 2.28.0 before 2.29.22. 1 more package is listed on the page.Source: cve.now feed data
How do I fix CVE-2026-121967?
Upgrade to a fixed version: 2.37.5, 2.36.8, 2.35.10, 2.34.13, 2.29.22, or one of 1 more.Source: cve.now feed data