FreeRDP before 3.32.2 Unauthenticated Denial of Service via CredSSP TSRequest
Affects FreeRDP before 3.32.2 when an NLA-enabled shadow server receives a CredSSP TSRequest that omits negoTokens. Fixed in 3.32.2.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- Proof of concept public, per CISA
- Fix
- Fixed in 3.32.2
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 3.32.2.
- Exploitation15/40CISA rates a proof of concept as public
- Exposure20/25No login or user action needed, CISA rates it automatable · Data gap: Advisories don't say whether default setups are affected
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity8.7/10CVSS 8.7
- No patch0/5No signal
What would change the score
- Would score about 74 if added to CISA KEV
- Would score about 69 if CISA's SSVC rates exploitation active
- Would score about 49 if advisories confirm default setups are exposed
CVE-2026-121960 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.7 (high) and affects FreeRDP; fixed in 3.32.2.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 44/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Unclear
- Fix
- Fixed in 3.32.2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: poc
- Automatable: yes
- Technical impact: partial
Summary
FreeRDP versions before the fixed release are affected when the shadow server with Network Level Authentication is enabled, which is a non-default setup, so the flaw only applies to that configuration. A remote attacker with no login can send a specially crafted, malformed authentication request that crashes the server process, causing a denial of service.
Read the original description
FreeRDP before 3.32.2 contains a denial of service vulnerability in the NLA-enabled shadow server when a CredSSP TSRequest omits negoTokens. Unauthenticated attackers can send a crafted seven-byte TSRequest containing only the version field to trigger a fatal WINPR_ASSERT and abort the server process.
What to do
Upgrade to a fixed version: 3.32.2.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: poc · Automatable: yes · Technical impact: partial
- Record last updated
Affected versions
- FreeRDP FreeRDP
fixed in 3.32.2
Evidence 2
- Advisory
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-121960
Is CVE-2026-121960 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. CISA's SSVC assessment notes a proof of concept exists. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
A remote client that is not authenticated can send a CredSSP TSRequest without negoTokens and abort the FreeRDP shadow-server process, which drops its client sessions. This is a denial of service.Source: vulncheck.com, github.com
Which versions are affected by CVE-2026-121960?
FreeRDP: before 3.32.2.Source: cve.now feed data
Am I affected, and how do I check?
FreeRDP versions before 3.32.2 are affected, but only shadow servers with NLA enabled and builds with assertions enabled, which is the default CMake setting WITH_VERBOSE_WINPR_ASSERT=ON. To check, look at the version FreeRDP reports and the WITH_VERBOSE_WINPR_ASSERT value used at build time.Source: vulncheck.com, github.com
How do I fix CVE-2026-121960?
Upgrade FreeRDP to version 3.32.2 or later.Source: vulncheck.com, github.com