FreeRDP before 3.32.2 Proxy Out-of-Bounds Write via Bitmap Cache v2 Capability
Only affects FreeRDP up to 3.32.1 when the freerdp-proxy is built with server and proxy support and used. Fixed in 3.32.2.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- Proof of concept public, per CISA
- Fix
- Fixed in 3.32.2
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 3.32.2.
- Exploitation15/40CISA rates a proof of concept as public
- Exposure20/25No login or user action needed, CISA rates it automatable · Data gap: Advisories don't say whether default setups are affected
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity10/10CVSS 9.3, total technical impact per CISA
- No patch0/5No signal
What would change the score
- Would score about 75 if added to CISA KEV
- Would score about 70 if CISA's SSVC rates exploitation active
- Would score about 50 if advisories confirm default setups are exposed
CVE-2026-121952 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 9.3 (critical) and affects FreeRDP; fixed in 3.32.2.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 45/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Unclear
- Fix
- Fixed in 3.32.2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: poc
- Automatable: yes
- Technical impact: total
Summary
A remote, unauthenticated attacker who can connect to FreeRDP's proxy component can trigger an out-of-bounds write there by declaring too few bitmap cache v2 cells during connection setup. This can corrupt heap memory, leak heap data to the backend server, or crash the proxy.
Read the original description
FreeRDP before 3.32.2 has an out-of-bounds write in the proxy because rdp_read_bitmap_cache_v2_capability_set rejects only numCellCaches values above 5, yet the bitmap cache v2 cell array is later accessed at fixed indices 0 through 4. A client connecting to the proxy can declare fewer than five cell caches in its Confirm Active, causing heap corruption, heap data leakage to the backend, or a crash.
What to do
Upgrade to a fixed version: 3.32.2.
Timeline
- CVE published
- First seen by cve.now
- Posted on X by cve.now
- CISA SSVC assessment
Exploitation: poc · Automatable: yes · Technical impact: total
- Record last updated
Affected versions
- FreeRDP FreeRDP
fixed in 3.32.2
Evidence 2
- Advisory
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-121952
Is CVE-2026-121952 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. CISA's SSVC assessment notes a proof of concept exists. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
A malicious client connecting through the FreeRDP proxy can trigger a 4-byte write past the end of a heap allocation. This can corrupt a neighboring heap object, leak adjacent heap contents to the backend server, or crash the proxy process.Source: github.com
Which versions are affected by CVE-2026-121952?
FreeRDP: before 3.32.2.Source: cve.now feed data
Am I affected, and how do I check?
Versions up to and including 3.32.1 are affected, but only where the freerdp-proxy component is used. The proxy must be built with WITH_SERVER=ON and WITH_PROXY=ON, and where the proxy configuration requires authentication, the client must authenticate first. The installed version can be checked with xfreerdp /version or freerdp-proxy --version.Source: github.com
How do I fix CVE-2026-121952?
Upgrade FreeRDP to version 3.32.2 or later, which contains the fix.Source: github.com