CoopCycle coopcycle-web before 6.20.1 IDOR via Incident Resource and Action Endpoint
Affects coopcycle-web v6.19.1 and earlier, where any authenticated courier account can reach incidents and other stores' tasks and orders. Fixed in 6.20.1.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- Proof of concept public, per CISA
- Fix
- Fixed in 6.20.1
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. Affects coopcycle-web v6.19.1 and earlier Attacker must be an authenticated courier account
- Exploitation15/40CISA rates a proof of concept as public
- Exposure8/25Specific setups only, reachable over the network
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity7.2/10CVSS 7.2
- No patch0/5No signal
What would change the score
- Would score about 65 if added to CISA KEV
- Would score about 60 if CISA's SSVC rates exploitation active
- Would score about 37 if CISA's SSVC rates it automatable
CVE-2026-121945 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.2 (high) and affects coopcycle-web; fixed in 6.20.1.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 30/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 6.20.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: poc
- Automatable: no
- Technical impact: partial
Summary
Any logged-in courier can remotely read and modify incidents belonging to other stores by enumerating sequential incident IDs, including re-pricing, cancelling, or rescheduling their orders and tasks. The flaw affects CoopCycle coopcycle-web, where incident operations only check for the courier role.
Read the original description
CoopCycle coopcycle-web before 6.20.1 contains a broken access control vulnerability that allows any courier to read and modify every incident because Incident operations only check ROLE_COURIER. Attackers can enumerate sequential incident ids and use PUT /api/incidents/{id}/action to re-price, cancel or reschedule other stores' orders and tasks.
What to do
Check whether your setup matches what the bug needs.
Affects coopcycle-web v6.19.1 and earlier Attacker must be an authenticated courier accountUpgrade to a fixed version: 6.20.1.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: poc · Automatable: no · Technical impact: partial
- Record last updated
Affected versions
- CoopCycle coopcycle-web
fixed in 6.20.1
Evidence 6
- Patch
- Exploit
- Report
- Repository
- Link
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-121945
Is CVE-2026-121945 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. CISA's SSVC assessment notes a proof of concept exists. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
An authenticated courier can read and modify any incident in the instance. They can also reschedule or cancel another store's task or order, apply an arbitrary price difference to it, and read customer identity.Source: hackmd.io, github.com, vulncheck.com
Which versions are affected by CVE-2026-121945?
coopcycle-web: before 6.20.1.Source: cve.now feed data
Am I affected, and how do I check?
coopcycle-web v6.19.1 and earlier, including the pinned commit, are affected. To check a deployment, find the coopcycle-web version it runs and compare it with 6.20.1.Source: hackmd.io, github.com, vulncheck.com
How do I fix CVE-2026-121945?
Upgrade coopcycle-web to 6.20.1 or later. The advisory lists no workaround.Source: hackmd.io, github.com, vulncheck.com